Reverse Proxy for Bookstack Docker version

I’ve run Bookstack on Docker and try to start using Bookstack, but it gets displayed the wrong way entirely. It seems like no style is loaded, at all, just HTML.

Now how do I set up my nginx vhost file, to properly load the styles? I tried different PHP related configurations but that failed.


Ad-Block and every other blocker is turned OFF (tested in a clean browser without browser extensions).

Thanks, will try that one out.

It is a sample for our letsencrypt container, so if you’re not using that, you’ll need to work through setting everything else up that is already templated in our container.

What exactly is needed besides following the standard setup?

check our configs, they’re available for your review.

So is this already part of the Bookstack image? I’m not sure how the description from your example applies to the Bookstack setup.

it is a reverse proxy sample included in our reverse proxy solution.

maybe i assumed wrong, are you NOT trying to reverse proxy bookstack?

As far as I know the image already has an Apache reverse proxy so I would need to reverse proxy through NGINX to get to the Apache reverse proxy. All I need to know is what I need to do to create a successful reverse proxy that uses the Docker image with the, I presume, already included reverse proxy which already has the PHP-specific configuration. I don’t know what PHP-specific settings I need to apply to my NGINX configuration.

there is no reverse proxy built into the bookstack image. If you want to reverse proxy, you need to make it yourself, or use ours for which we have a bookstack template.

Okay, I see now. So the template from Reverse Proxy for Bookstack Docker version should be enough I guess. I will try it out.

yes, but note that the template references our proxy.conf and ssl.conf from our reverse proxy container.

No problem, I just need the part that makes PHP work.

Hey, I tried out the configs you showed me a couple of times and it worked after some adjustments! Most importantly, the configuration won’t work without Let’s Encrypt or other SSL methods. Thank you very much!

my pleasure, make sure you mark something as a solution if i provided it or post your own solution and mark it so future readers can solve similar problems!

I know how to mark a post as a solution from other Discourse-based fora, though I don’t see a checkmark button here. Maybe I don’t have enough reputation and therefore permission yet, or the category chosen for the thread does not provide a solution option.

I would kind of be nice for you to post a working solution rather than say I solved it without explanation. That’s kind of not nice.

1 Like
  1. I posted the solution with an explanation.
  2. What’s your problem?