A problem has been detected with a core component of Plex Media Server

I’ve been trying for the last couple of days to install Plex Media Server on my Raspberry Pi 4 which is running Openmediavault 5.5.19-1. I’m trying to install the linuxserver/plex image using Portainer, but every time the container is created and I try to access the Plex web interface, it gets stuck on the setup page followed by the core component error while the Pi’s processor gets stuck at 100% usage. I’ve tried all I could think of to debug it, but to no success. The Portainer log for the plex container (posted below) shows a few errors but I could not find a solution for it online. If anyone could shed some light on this, it would be much appreciated.


[s6-init] making user provided files available at /var/run/s6/etc…exited 0.,
[s6-init] ensuring user provided files have correct perms…exited 0.,
[fix-attrs.d] applying ownership & permissions fixes…,
[fix-attrs.d] done.,
[cont-init.d] executing container initialization scripts…,
[cont-init.d] 01-envfile: executing… ,
[cont-init.d] 01-envfile: exited 0.,
[cont-init.d] 10-adduser: executing… ,
_ (),
| | ___ _ _,
| | / | | | / \ ,
| | _
\ | | | () |,
|| |
/ || _/,
Brought to you by linuxserver.io,
To support LSIO projects visit:,
User uid: 1001,
User gid: 100,
[cont-init.d] 10-adduser: exited 0.,
[cont-init.d] 40-chown-files: executing… ,
[cont-init.d] 40-chown-files: exited 0.,
[cont-init.d] 45-plex-claim: executing… ,
[cont-init.d] 45-plex-claim: exited 0.,
[cont-init.d] 50-gid-video: executing… ,
[cont-init.d] 50-gid-video: exited 0.,
[cont-init.d] 60-plex-update: executing… ,
Docker is used for versioning skip update check,
[cont-init.d] 60-plex-update: exited 0.,
[cont-init.d] 99-custom-scripts: executing… ,
[custom-init] no custom files found exiting…,
[cont-init.d] 99-custom-scripts: exited 0.,
[cont-init.d] done.,
[services.d] starting services,
[services.d] done.,
Starting Plex Media Server.,
Error in command line:the argument for option ‘–serverUuid’ should follow immediately after the equal sign,
Crash Uploader options (all are required):,
–directory arg Directory to scan for crash reports,
–serverUuid arg UUID of the server that crashed,
–userId arg User that owns this product,
–platform arg Platform string,
–platformVersion arg Platform version string,
–vendor arg Vendor string,
–device arg Device string,
–model arg Device model string,
–sentryUrl arg Sentry URL to upload to,
–sentryKey arg Sentry Key for the project,
–version arg Version of the product,
–allowRetries arg Whether we will allow retries,
Error starting framework core for /usr/lib/plexmediaserver/Resources/Plug-ins-6c22540d5/Musicbrainz.bundle.,
Error starting framework core for /usr/lib/plexmediaserver/Resources/Plug-ins-6c22540d5/Fanart-TV.bundle.,
Error starting framework core for /usr/lib/plexmediaserver/Resources/Plug-ins-6c22540d5/PlexMusic.bundle.,

Your are running into this.

Much appreciated, going to check it out and report back.

Indeed it worked. Followed the GitHub link for method 3 and everything works now. Thank you very much, going to mark your comment as the solution.
Happy holidays,

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.