All my containers stopped and not showing

Hello all,

I have for years been running Nextcloud, MariaDB, Plex and more from my CoreElec box. Everything has worked perfectly, but suddenly a few days back all containers shut down and are not showing up now also after reboot. In the logs found in my /Kodi/userdata/addon_data/“any of the missing apps” they have all been shut down on the same timestamp and not restarted afterwards.

“docker ps -a” command does not show my containers.

I believe it must be docker itself which has a problem - I am quite a novice, are there any known commands for rebuilding? All my docker image files and userdata seems unchanged.


Argh, I got this terrible message:

● docker.linuxserver.nextcloud.service - docker.linuxserver.nextcloud container
     Loaded: loaded (/storage/.kodi/addons/docker.linuxserver.nextcloud/system.d/docker.linuxserver.n
     Active: active (running) since Wed 2023-10-18 02:38:38 CEST; 31min ago
   Main PID: 3940 (sh)
      Tasks: 2 (limit: 3703)
     Memory: 1.3M
     CGroup: /system.slice/docker.linuxserver.nextcloud.service
             ├─3940 /bin/sh /storage/.kodi/addons/docker.linuxserver.nextcloud/bin/docker.linuxse
             └─4040 sleep infinity

Oct 18 02:38:38 CoreELEC systemd[1]: Started docker.linuxserver.nextcloud container.
Oct 18 02:38:38 CoreELEC sh[3940]:   **************************************************************
Oct 18 02:38:38 CoreELEC sh[3940]:   **************************************************************
Oct 18 02:38:38 CoreELEC sh[3940]:   ****            You are using 32 bit userspace            ****
Oct 18 02:38:38 CoreELEC sh[3940]:   ****       Linuxserver has deprecated 32 bit images       ****
Oct 18 02:38:38 CoreELEC sh[3940]:   **** ****
Oct 18 02:38:38 CoreELEC sh[3940]:   ****         This addon will not run on your system       ****
Oct 18 02:38:38 CoreELEC sh[3940]:   **************************************************************
Oct 18 02:38:38 CoreELEC sh[3940]:   **************************************************************

Is there anyway to roll back? CoreElec is not updating their userspace to 64bit …

Some users reported that on LibreELEC 11 arm32, the 64 bit images are working.

In a few days I’ll update the addons to use the 64 bit images on arm32 instead. It may or may not work on coreelec, no idea.

Thanks, that would be nice. However, I think this code-snippet evaluating the 32bit userspace seems to kill the process and does not allow it to be executed further… Most of the tools I use e.g. Nextcloud still have 32bit support in their newest versions, so why not let the enduser decide which version to run instead of forcing an unsupported upgrade?

Do me a favor, ssh into your device and do docker run linuxserver/nextcloud and see what you get.

Once you’re done, you can give this a read: 32-bit Arm Deprecation Notice | Info ::

tl;dr We are not forcing anything. Your device is no longer officially supported. We deprecated arm32 images a while back. I should perhaps leave it as is.

I am sorry if my wording in the previous post seemed impolite. I have been very, very happy with all the linuxserver packages especially Nextcloud which backs up all the family photos. I must admit that I became a bit desperate when all my services had shut down. And now I regret that I had not followed the site news and turned off auto-update function.

I get this error when running the command:

**CoreELEC:****~** # docker run linuxserver/nextcloud
Unable to find image 'linuxserver/nextcloud:latest' locally
latest: Pulling from linuxserver/nextcloud
docker: no matching manifest for linux/arm/v8 in the manifest list entries.
See 'docker run --help'.


Ii have done some more testing and indeed they work well with the arm64v8 versions.

I managed to get all my docker addons working again by modifying the files in the addons folder for each add-on – e.g. /storage/.kodi/addons/docker.linuxserver.plex/bin/docker.linuxserver.plex

I had to delete the part where it checks for the 32bit system leading to sleep infinitely.

It had to be forced to use an “arm64v8” tag when updating the images instead of “latest”:

#set docker image

and further change the same files by adding this $DOCKERIMAGETAG to the auto-updater part - replace with this code:

if ! grep -q "$DOCKERIMAGE" /storage/.kodi/userdata/addon_data/docker.linuxserver.updater/; then
  echo "/storage/.kodi/addons/service.system.docker/bin/docker pull ${DOCKERIMAGE}:${DOCKERIMAGETAG}" >> /storage/.kodi/userdata/addon_data/docker.linuxserver.updater/

and also it needs the very last line changed from “$DOCKERIMAGE”:latest to: