Calibre - gui password "error: login failed for disaplay 0"


I tried setting the password as qwe or md5 hash of qwe in the docker compose of LSIO’s calibre docker - but it is not working.

I tried to login with username : abc , password : qwe and session : xorg
Is there anything I have to do?
If I set the password as empty and run the docker compose the gui comes up immediately.
Any help will be helpful! thank you!

It accepts a password, not a hash

Thank you.

I tried both : a password and a md5 of the password. Both doesn’t work.
I tried multiple times.

session : xorg
username : abc
password : qwe

Anything different I have to do?

Instead of telling us what you did, show us. Post your compose yaml and logs

This is my compose file :

version: "2.1"
    container_name: calibre1
      - PUID=1000
      - PGID=1000
      - TZ=America/New_York
      - PASSWORD=qwe
      - CLI_ARGS= #optional
      - /shared-path/docker-mounts/KK-Calibre:/config
      - 19820:8080
      - 19821:8081
    restart: unless-stopped

I just did docker run -d --rm --name test -p 8080:8080 -e PASSWORD=qwe and logged in with abc:qwe with no issues

probably worth providing the docker logs as well. that volume makes me think you have some remote mount or usb type deal or something and this could be related to permissions issues. Please use a pastebin-like service to share your container logs

I’m sorry everyone - there was a space between the password and = sign. It is working fine now. Thank you! Once I pasted the compose file here - I found a space and corrected it here and checked in mine. And it started working. Sorry again. And thank you!!

thanks for the update, have fun!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.