Calibre (NOT-web) container password

For the calibre container (not calibre-web), I cannot seem to change the default guac pass.
No matter what I md5 hash and pass to the environment variable (either as a FILE__ or straight string), the password remains the default abc. The GUAC_USER works fine just not the password.
I have tried multiple hashed passwords including abd and cba.
Any clues as to the problem?

docker-compose yml config below, using a env file for the variables.

image: linuxserver/calibre
container_name: calibre
- PUID=$UserID
- PGID=$GroupID
- TZ=Europe/London
- GUAC_USER=exodus #optional
#- FILE__GUAC_PASS=/home/user5/.password_md5 #optional
- GUAC_PASS=3944b025c9ca7eec3154b44666ae04a0
- $AppsDir/calibre:/config
- $BooksDir:/books
- $ComicsDir:/comics
- $DownloadsDir:/downloads
- $SortDir:/sort
- $BlackholeDir:/blackhole
- 8180:8080
- 8181:8081
restart: unless-stopped

cba for password works here

~$ echo -n cba | openssl md5
(stdin)= 3944b025c9ca7eec3154b44666ae04a0
docker run -d --rm --name test -e GUAC_USER=abc -e GUAC_PASS=3944b025c9ca7eec3154b44666ae04a0 -p 8080:8080 linuxserver/calibre

I login with abc:cba

and yet I can’t login with it, hence my confusion.
I’ve tried to stop the container and remove the mapped files and restart but it still accepts the original password.

you’re doing docker-compose up -d, right?

I was yes, a restart of the server fixed it for some reason?
I can only imagine that it was keeping an instance of the old docker-compose file in memory so my changes didn’t mean anything. Possibly as the file was used as part of a larger docker-compose up -d.