Calibre (not web) mobile version - mouse problem iOS 13

Hello Guys
I started using docker last week on my synology ds418play and it’s great
I have one little problem though
I installed Calibre (not web) and Calibre web to check them out
Calibre is doing everything I need except it is not usable on a mobile device (specifically an iphone). The mouse is acting crazy, so I can’t edit metada for example
Calibre web is great for mobile but there is no auto & mass import of files through a watch folder and even with a single file, I can’t get it to convert to mobi
For the mouse problem, am I the only one to have this problem or is it specific to guacamole ? I searched for similar topics everywhere but no luck
Thanks a lot for any help

I just found this topic. This may be related to iOS 13:

Can anyone with an android device and calibre tell if it is okay for them?
Can the calibre image use the guacamole 1.2 version ?

Many thanks

I swipe in from left to open the menu and change mouse to touch mode. It works just fine on Android

Thanks for the feedback. I have tried to do the same with an iPad and an iPhone, I can get access randomly to the menu but I cannot change the mode, I managed to change it once after trying dozen of times but it doesn’t work as well.

Dear tchirou

which port do you use on iOS - the “regular” “main” entrance port 8080 or the content entrance 8081?

By 8081 you get a different GUI - with less options but it works fine for me on my iPAD 10.5


Hi Henning

I was talking about the regular one. My need was to be able to edit metadata, including title_sort and author_sort
After my posts from yesterday, I indeed tried the content server which has a usable GUI. I found out that if I edited author and title, it changed also the title_sort and author_sort. When the title and author are already right, I need to make one wrong, apply the changes, make it right again, apply the changes, and same thing for the other one. A bit tedious but a working workaround nonetheless.

Nevertheless, I think that the impossibility so far to use the regular calibre with iOS devices should be looked at if possible.

Thanks for the advice though

Have a nice day.

Dear tchirou

I confirm your findings.
I locked into calibre (port 8080) by iPad Pro 10.5. From the left corner comes in a “pop-up” to define curser movement and virtual typing. BUT I was not able to change any settings.

I’m not sure this is a docker specific problem. It might be a calibre problem?!?


Thanks for checking

It is a guacamole problem :

What version of iOS do you use ? 13 ?


My iPad Pro 10.5 uses PadOS 13.4.1

So a guacamole problem which could maybe be resolved with 1.2.0 version
@aptalca do you think you could take a look at this ?
Many thanks

In the near future, the calibre image will move to a new baseimage that uses up to date guacamole. I have a few projects ahead of that one though

Just a side note this is being also held up by an issue with building focal based images for armhf. One of the reasons we are held back to guacd 1.0.0 on our related stuff.

When this branch builds again we can start putting 1.1.0 in all our stuff and 1.2.0 when it drops

Has to do with the freerdp2 packages in bionic.

Thanks for all your feedbacks