Calibre-Web container not starting after update (solved)

Just updated my calibre-web docker container with the latest version from docker hub on my Synology NAS. The container doesn’t start, in the log there are multiple errors

ModuleNotFoundError: No module named 'flask'

Traceback (most recent call last):

  File "/app/calibre-web/", line 28, in <module>

    from cps.main import main

  File "/app/calibre-web/cps/", line 28, in <module>

    from flask import Flask

Is there a bug in the latest build?

best regards,

More likely to be Synology

Oops, didn’t see that before, assumed since the last dozen or so times I updated the container it worked like a charm, the problem must be the image.

Sorry, you are right, it’s a Synology problem. Deleting old container including image and docker config and then recreating plus redownloading fixed the problem. Less radical measures (duplicating settings, exporting/importing settings) wasn’t enough. No changes in the local folder needed though, so it was still a breeze.

Thanks for the quick response and pointing in the right direction.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.