Calibre-web "Read in Browser" is missing

Moved my docker container to a new host using the same storage. Container starts no problem and is accessible but “Read in Browser” is missing when I open a book. I can only download. I have verified with both a txt and epub

It was working prior to the host move? can you provide your docker run/compose, host os/version, and error logs? thanks.

So when I moved froma raspberry pi to my ReadyNas 626 (ARM to Intel) I copied the database over and recreated the container with portainer. It started up no problem with the missing button the only issue I have found. My original instance is still running as well. I am trying to find a way through portainer to export the settings
Host is ReadyNAS 626 running 6.10.2 and Docker version 18.06.3-ce. Below are the container logs:

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.,
[s6-init] ensuring user provided files have correct perms…exited 0.,
[fix-attrs.d] applying ownership & permissions fixes…,
[fix-attrs.d] done.,
[cont-init.d] executing container initialization scripts…,
[cont-init.d] 01-envfile: executing… ,
[cont-init.d] 01-envfile: exited 0.,
[cont-init.d] 10-adduser: executing… ,
,
-------------------------------------,
_ (),
| | ___ _ _,
| | / | | | / \ ,
| | _
\ | | | () |,
|| |
/ || _/,
,
,
Brought to you by linuxserver.io,
We gratefully accept donations at:,
https://www.linuxserver.io/donate/,
-------------------------------------,
GID/UID,
-------------------------------------,
,
User uid: 1000,
User gid: 1000,
-------------------------------------,
,
[cont-init.d] 10-adduser: exited 0.,
[cont-init.d] 30-config: executing… ,
[cont-init.d] 30-config: exited 0.,
[cont-init.d] 99-custom-scripts: executing… ,
[custom-init] no custom files found exiting…,
[cont-init.d] 99-custom-scripts: exited 0.,
[cont-init.d] done.,
[services.d] starting services,
[services.d] done.,

My apologies but this was a case of stupidity on my part. Apparently by default the admin user is not allowed to view ebooks in the browser. You need to be a separate user with it enabled or to go into the interface and enable it for the admin user. I am sorry to have taken your time on this. I appreciate your help and hope you have a wonderful day. Thanks again for looking at this!

hah no worries, that explains why i couldn’t recreate it no matter what i did… i just never logged in as the admin user… glad you got it sorted