Calibre-Web upload of .mobi files not working on Synology NAS

Hi all,

First of all thanks for the amazing container! Mostly everything is working fine, there is only one problem with uploading .mobi files - maybe you are able to help me fix it.

When I am trying to upload .mobi files, they are always greyed out in the explorer. I checked all settings and tried different file types with the same result: For all files everything is working as expected, adding or deleting the filetype from the feature config works as expected, but not for .mobi files. I am unable to select them for upload.

Do you have any ideas what I could do? I am using the latest container build.

Anyone here having an idea how to fix the issue?

can you provide more detail? I was not aware of any upload functionality, can you take a screen shot of what you’re trying to do?

Thanks for your reply!

Okay here are some pictures that hopefully clarify my situation.

  1. In the Admin panel > Feature configuration I enable upload and configure the allowed file types. „Mobi“ is one of them.

  2. I click the „upload“ bottom at the top of the calibre-web UI and try to upload an ebook file. (Screenshot deleted, as new user can only post one image)

  3. The upload works as expected for all file types as configure in step 1, but it doesn’t for .mobi files. As you can see in the image, the mobi file is greyed out. The screenshot is taken from an iPad, but other devices behave in the same way.
    (Screenshot deleted, as new user can only post one image)

Any idea how to solve this issue?

Ill have to see myself out of this one, I had no idea you could upload, thanks for showing me this! I may try to play with it tonight and get back to you, but maybe someone else will know the answer.


update: i just enabled uploading and successfully uploaded a .mobi file. I think your best bet is to engage the calibre-dev and upload logs to them. I did only test this from a pc broweser