Can’t start Nextcloud

Hi All,

My nextcloud on docker wont start! My Nextcloud Docker Image was updated automatically by watchtower.

I am getting the error message as ‘Can’t start Nextcloud because the version of the data ( is more than one major version behind the docker image version ( and upgrading more than one major version is not supported. Please run an image tagged for the major version 26 first.’

So I follwed instructions as per this article - Notification: Changes to our Nextcloud image | Info ::

My Current Nextcloud Config
\nextcloud\www\nextcloud\config\config.php ==> ‘version’ => ‘’,
\nextcloud\www\nextcloud\version.php ==> $OC_VersionString = ‘26.0.2’;

I tried changing the image in my Docker Compose file to
and recreated the container and executed docker exec -it nextcloud updater.phar
Following comes up
Nextcloud Updater - version: v26.0.0beta2-9-g64e2e4c dirty
Current version is 26.0.2.
Update to Nextcloud 25.0.9 available. (channel: “stable”)

When I say continue it errors out
[:heavy_check_mark:] Check for expected files
[:heavy_check_mark:] Check for write permissions
[:heavy_check_mark:] Create backup
[:heavy_check_mark:] Downloading
[:heavy_check_mark:] Verify integrity
[✘] Extracting failed
Downloaded version is lower than installed version

Update failed.

I tried using lower version image as well but i still get above error.
Please help with this issue.
Thank you in adavance.

1 Like

I don’t have any answers for you - but I did have the same problem. In the end, I ended up creating an entirely new Nextcloud setup. Copied all of my files over, occ file:scan, etc. Major pain. Nextcloud updates are horrible.

Exact same issue here…

Thanks, I wanted to avoid this, but it seems the only way to go ahead!

Sorry to bring up an old post, but has anyone found a way to resolve this without copying everything over?