Can't add transmission as a Sonarr download client

I’m using the recommended docker-compose method to create a container that has jackett, transmission, sonarr, radarr and plex. I have managed to get indexers setup in jackett and sonarr to query those indexers. I have transmission running and I can access it’s web interface with no problem at all. When I try to add transmission to sonarr I get and authentication error with a red exclamation mark in the username field. I have added to the docker-compose.yml file the following statements

        - WHITELIST=127.0.0.1,192.168.10.* #optional
        - HOST_WHITELIST=sonarr,radarr #optional

and the rpc section of the settings.json file of transmission looks like this

"rpc-authentication-required": false,
"rpc-bind-address": "0.0.0.0",
"rpc-enabled": true,
"rpc-host-whitelist": "sonarr,radarr",
"rpc-host-whitelist-enabled": true,
"rpc-password": "{a20ebde66afb6bf09cf97cb9752e7dac4d6ad571mUbDw5L2",
"rpc-port": 9091,
"rpc-url": "/transmission/",
"rpc-username": "",
"rpc-whitelist": "127.0.0.1,192.168.10.*",
"rpc-whitelist-enabled": true,

The rpc-password string changes every time I bring up the container and I tryed setting no user or password, some password like “admin” or even the string in the rpc-password when trying to add transmission as a download client in Sonarr, none of the above work. I’m looking into how to set rpc-authentication-required to true and setting the rpc-username but haven’t found any docs with info on how to accomplish this (without modifying the settings.json file by hand).

Could anyone please provide some info on what I’m missing?

Thanks in advance.

OK, so I tried adding a user and pass in the docker-compose.yml file

    environment:
        - PUID=1000
        - PGID=1000
        - TZ=America/Argentina/Buenos_Aires
        # - TRANSMISSION_WEB_HOME=/combustion-release/ #optional
        - USER=transmission #optional
        - PASS=transmission #optional
        - WHITELIST=127.0.0.1,192.168.10.* #optional
        - HOST_WHITELIST=sonarr,radarr #optional

and now I have to input the user and pass to acces the web frontend to transmission but I’m still getting the authentication error in sonarr even though I’m entering the correct username and password. Could it be something wrong in the HOST_WHITELIST variable?

Sorry, I replied forgetting that I’m using a different Transmission container, not the LinuxServer one.

OK, I was able to add the client and I’m posting this in case it saves someone the hassle. I found out the internal address of the guest by logging into the transmission container (the sonarr container doesn’t even have a ping command) with the following command

sudo /usr/bin/docker exec -ti transmission /bin/bash

and in there i did

ping transmission

which answered

PING transmission (172.22.0.5): 56 data bytes
64 bytes from 172.22.0.5: seq=0 ttl=64 time=0.102 ms
64 bytes from 172.22.0.5: seq=1 ttl=64 time=0.086 ms
64 bytes from 172.22.0.5: seq=2 ttl=64 time=0.077 ms

with this I then modified my docker-compose.yml with the following

        - WHITELIST=127.0.0.1,172.22.0.*,192.168.10.* #optional

I fired up the guest again and it worked like a charm.

1 Like