Can't run docker on NAS

I have a synology NAS upgrade to DSM 7.0.
When I run calibre-web docker it shows an error:

socket.timeout: _ssl.c:1114: The handshake operation timed out

I have tried 2021.10.16/2021.10.25/last version, it always shows the same error.
anyone can help me? thanks

What command are you using to start it?

default command from Synology NAS docker

Are you saying you’re running it from the web interface and not the command line?

yes, synology nas has a web interface to run docker

Yes, I know and I don’t use it. I start my containers from the command line.

Try ssh’ing in to your Synology (which model is it, btw?) and running this command

docker run -d --name=calibre-web \
-p 8083:8083 \
-e PUID=1024 \
-e PGID=101 \
-e TZ=Europe/London \
-e DOCKER_MODS=linuxserver/calibre-web:calibre \
-v /volume1/docker/calibreweb:/config \
-v /volume1/web/books:/books \
--restart always \

You’ll have to change the paths to match your setup. Just tried it on my DS918+ and it worked.

I tried the comand and can run the docker image, but still can’t see from web-browser
and I can’t see any error with “docker logs”

I’m just checking - you’re going to http://serverip:7003 in your browser? Not serverip:8083

If so, what does your browser say - even if it’s just “This site can’t be reached”?

What happens if you type


in to the Synology command line?

OK, that implies the container started. Does

docker logs calibre-web

say anything useful? And - just checking - you haven’t enabled the DSM firewall (Control Panel > Security > Firewall)?

I found an error log…