Connecting two separate container (database and program) not working

I got this far reading as well as a post regarding TT-RSS here but nothing is working

Having trouble connecting these two separate containers

mariadb setup

docker create
-e PUID=1000
-e PGID=1000
-e TZ=America/Regina
-p 3306:3306
-v /server/data/mariadb:/config
–restart unless-stopped
–net databasenetwork

projectsend setup

docker create
-e PUID=1000
-e PGID=999
-e TZ=America/Regina
-e MAX_UPLOAD=4096
-p 5555:80
-v /server/data/projectsend/config:/config
-v /server/data/projectsend/data:/data
–restart unless-stopped
–net databasenetwork

Network setup
xxxxxxxxxxx databasenetwork bridge local

When I go to the projectsend site on my system to configure the database I cannot figure out what to put in the settings

Select Driver: MySQL
Host: ??? (have tried localhost, mariadb, the ip from the network inspect, the sites address both FQDN and ip)(all by themselves and with :3306 after them.
Database Name: xxxx
Username: xxxx
Password: xxxx

I have gone into the mariadb container and setup the database and user privileges, I think if I can get the host right the others will turn green checks (vs Red warning signs) :smile:


Haven’t used projectsend, but a common config issue with mariadb is, if you created your user and gave permissions to database with @'localhost', it won’t work. It needs to be @'%'

Alternatively, you can have the mariadb container create the database and the user for you by using the optional arguments listed on its github (only works during first set up, so start with a fresh config folder).

Then once the database and the user is set up and the containers are in the same network (seems like you got that part right), mariadb should be reachable at mariadb or mariadb:3306

Thank you @aptalca that is exactly what I needed, everything is working now.