Creating Multiple Transmission Instance

transmission

#1

Hi,

I was testing docker in a Ubuntu 18.04 VM. I wanted to try and create multiple transmission instance. Managed to do it using docker-compose as following:

transmission-hdx:
    container_name: transmission-hdx
    image: linuxserver/transmission
    restart: always
    volumes:
      - /srv/docker/transmission-hdx/config:/config
      - /srv/docker/transmission-hdx/downloads:/downloads
      - /srv/docker/transmission-hdx/watch:/watch
      - /etc/localtime:/etc/localtime:ro
    ports:
      - "9091:9091"
      - "51413:51413"
      - "51413:51413/udp"
    environment:
      - PGID=998
      - PUID=1000

Did it two more times, with ports number +1. However, I can only access the container with port 9091 on webui. 9092 and 9093 doesn’t work until I edit the rpc-port and peer-port in the settings.json file manually. Is there an option to add them into the docker-compose file itself?

I tried RPC_PORT=9092, RPC-PORT=9092 as well as rpc-port=9092 under the environment variable but didn’t work.

Any help is appreciated.

Thank you.

P/s:
docker ps -a [for the other two transmission has the following]

9091/tcp, 0.0.0.0:9092->9092, 51413/tcp, 0.0.0.0:51414->51414, 0.0.0.0:51414->51414/udp
9091/tcp, 0.0.0.0:9093->9093, 51413/tcp, 0.0.0.0:51415->51415, 0.0.0.0:51415->51415/udp

9091/tcp and 51413/tcp seems to be defaulted into the setting. Even after manually editing settings.json file, it’s there but i can view the webui.


#2

Well, I’m an idiot.

Figured it. Made mistake when assigning the ports.

Tried a completely new one with the following setup:

version: '3'
    
    services:
    
        transmission-hdx:
            container_name: transmission-test
            image: linuxserver/transmission
            restart: always
            volumes:
              - /srv/docker/transmission-test/config:/config
              - /srv/docker/transmission-test/downloads:/downloads
              - /srv/docker/transmission-test/watch:/watch
              - /etc/localtime:/etc/localtime:ro
            ports:
              - "9094:9091"             
              - "51416:51413"
              - "51416:51413/udp"
            environment:
              - PGID=998
              - PUID=1000

“9094:9091” I assumed its docker port:host port when its host port:docker port. Plus some wrong port numbers.

So sorry for the trouble!


#3

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.