Deluge doesn't start correctly after update

deluge

#1

Firstly my system:

Linux openmediavault 4.9.0-0.bpo.6-amd64 #1 SMP Debian 4.9.88-1+deb9u1~bpo8+1 (2018-05-13) x86_64 GNU/Linux

Docker version 17.05.0-ce, build 89658be

Linuxserver.io version:- 144 Build-date:- October-26-2018-22:11:29-UTC

Since the latest update my deluge container doesn’t bring up the webui anymore. It is started via docker-compose:

 deluge:
        image: linuxserver/deluge
        container_name: deluge
        restart: always
        volumes:
            - /xxxxxx/deluge:/config
            - /xxxxxxxx:/downloads
        ports:
            - 5010:5010
            - 5011:5011
            - 5012:5012
            - 5013:5013
            - 5014:5014
            - 5015:5015
            - 5016:5016
        environment:
            - PUID=2006
            - PGID=100
            - UMASK_SET=002
            - TZ=Europe/Berlin            
        expose:
            - 5010

The log output is this:

https://pastebin.com/PaKXaREA

Any idea what is going wrong?


#2

@namron Interesting, could you try the previous tag for deluge? add :143 to the end of the image name and see if the webui pops up?

Also spotted that your version of docker is from May '17, any reason it’s not running something newer?

And well done on the first support post :stuck_out_tongue:


#3

Hi,

downgrading to the 143 tag didn’t help.

I installed docker from the official repo for Debian 8 (https://apt.dockerproject.org/repo debian-jessie main). The version I have seems to be the most recent available in the repo.

EDIT:
I run other linuxserver.io images (nzbget, emby, sonarr) and they work fine.

Also I tried deleting the deluge config folder, which didn’t help


#4

Just tested this container myself and it’s working here on a fresh run:

docker create \
  --name deluge \
  --net=host \
  -e PUID=1000 -e PGID=1000 \
  -e TZ=Europe/London \
  -e UMASK_SET=022 \
  -v /home/j0nnymoe/appdata/deluge:/config \
  linuxserver/deluge

#5

Using
--net=host
fixed it for me.
When did this change? I always used to assign ports by hand.


#6

The documentation has always stated host networking for this container but no why it would suddenly change for you as we haven’t done any (major) changes on it for months.


#7

Weird.

Thank you for the help.


#8

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.