Deluge error - Freespace in download folder

Hi all,

I’m getting an error in Deluge that’s preventing downloads from beginning - “freespace in download folder”

I understand that this is a common issue that comes up and is related to not linking the deluge download folder to the one specified within the docker compose file.

I think I’ve done this correctly but still getting the problem?

Docker compose:

version: "2.1"
    container_name: deluge
      - PUID=1000
      - PGID=1000
      - TZ=Australia/Sydney
      - DELUGE_LOGLEVEL=error #optional
      - /home/pi/deluge/config:/config
      - /home/pi/Downloads/torrentsdl:/downloads
      - 8112:8112
      - 6881:6881
      - 6881:6881/udp
    restart: unless-stopped


Thanks all

You should be keeping the download folder to /downloads. Deluge has no knowledge of your hosts folder path.

1 Like

Hi, thank you for the response.

This was one of the things I tried (and just tried again), but still have the same issue.

From my readings it seems like Deluge does know what folder to use since it’s specified in the docker compose file:

      - /home/pi/deluge/config:/config
      - /home/pi/Downloads/torrentsdl:/downloads

and it’s very picky if you don’t use this specific folder - although I could be wrong and misinterpreting.

That’s purely a mapping that This/folder/here/maps/to:/Folder-Inside-Container

You’ve probably filled up your host by storing your files within the container.

So it sounds like I’ve broken it? What should it be & do I need to do?

I had the default:

      - /path/to/deluge/config:/config
      - /path/to/your/downloads:/downloads

But I realised that it created the “/path/to/your/downloads” folder structure as the location of my downloads folder, so I understood that as being the variable (green text on my screen) that could be changed to my desirable location.

Nothing is downloading anyway - it starts off very slow and then drops off/stops.

Hi, I’m not sure what I might next need to do. Would appreciate any advice or help.

Thank you

If your paths are correct, I think with deluge you need to set the downloads folder within the app to /downloads

Hi, I’ve tried this but it doesn’t work. I believe the path should be:


But that doesn’t work either. I was of the understanding that:

“this is the custom path you can choose”:/downloads

As when I used the default it actually mapped out the downloads into “/path/to/your/downloads”

No, within deluge yourself, you need to set it to /downloads - Deluge inside the container has no knowledge of paths on your host.

Yep - done that. I’ve had a working configuration before with Deluge through docker compose as above using the default pathway.

I am aware that you need to include the pathway in Deluge itself as it doesn’t self populate. I wasn’t happy with the default pathway as it placed a new folder structure on my Pi under “/path/to/your/downloads“.