Deluge image - synology NAS - unable to install AutoRemoverPlus (SOLVED)

I am running the latests docker image (2.0.3) on my Synology NAS. I am not having any issues running the docker and the container is working as expected. However, I want to install the plugin AutoRemoverPlus. According to this website ( ) it should work with WebUI. However, when I place the AutoRemovePlus-0.6.1-py2.7.egg in the /volume1/docker/DockerDeluge/config/plugins folder. It does not appear in the plugins. The synology is running Python 2.7 - which matches the egg.

Any ideas on how I can get this to work?

You need to use the python3 versions as that’s what’s running within the deluge container.

The Python3 “versions” of deluge or you mean I need to use Python 3?

Python3 version of that plugin. Python3 is used within the container so 2.x versions aren’t going to work.

I’ve also tried AutoRemovePlus-0.6.2-py3.7 which I found at But no luck.

So it doesn’t matter that my NAS is using Python 2.7?

Thanks for the help.

Nope, the version on the host is irrelevant

I found a solution:

If you’re using the linuxserver/deluge docker image you will need to rename AutoRemovePlus-0.6.2-py3.7.egg to AutoRemovePlus-0.6.2-py3.6.egg when placing it in the plugins directory. After doing this and restarting the docker container the plugin showed up.

For anyone else finding this problem this worked for me.

Thank you for your assistance.