Diskover crawler cannot crawl '0700 root root' directories

There is a major directory tree (/var/lib/docker) that I want diskover to crawl (so I can monitor volume growth) but the permissions of most of the top level directories in it are:
drwx------ root root

Solutions tried:

  1. Run diskover as root
    The linuxserver.io diskover container will not start as PUID=0 so this will not work.

  2. Change host directory permissions
    I do not want to change the permissions of the docker directory tree.

  3. Use group access
    Since the group access for these directories is 0, I cannot resolve this by adding user 1000 to a group 0 (which I would not want to do anyway).

  4. Elevate container privileged
    I have tried using, CAP_DAC_READ_SEARCH, CAP_DAC_OVERRIDE and even “privilege: true” but user 1000 on the host does not have access to these directories so this will not work.

I raised this as an issue on github a couple of weeks ago but no response as yet.

Any ideas (that preferably don’t involve changing the docker directory permissions)?

[Note: discourse requires a tag and I could find a suitable one or create one so chose ‘nginx’ - sorry]