Docker Newbie question Couchpotato (Docked) not working with Utorrent (undocked)

I’m having a bit of a brainfart with trying to use the couchpotato docker to work with utorrent, and I’m hoping perhaps someone could tell me what I’m doing wrong. I’m a bit new with docker however I was able to couchpotato MOSTLY working with the exception of the “test” utorrent connection.

I have a non-docked couchpotato that can use utorrent on the same network just fine.

sudo docker create --name=couchpotato
–restart=always
-v /home/docker/couchpotato/config:/config
-v /home/docker/couchpotato/downloads:/downloads
-v /Windows/Natasha/Movies:/movielink \ -> a mapped drive to my NAS
-e PGID=1001 -e PUID=1001
-e TZ=Europe/London
-p 5050:5050
-p 8090:8090 \ -> tried this just for fun, that didn’t work
linuxserver/couchpotato

so I have utorrent running on a separate server at http://10.0.0.116:8090/


so in the settings (under Downloaders) there is a utorrent selection that (and I know I have the username/password correct), the Test will not work.

Is there a setting I am missing? Docker shell access of couchpotato allowed me to ping the server no problem. Is this just a port issue? Should I be adding a bunch of ports for utorrent or something? I’m a bit lost, thank you for any assistance. Again Utorrent is not in a docker, and my “undocked” (is that a term) couchpotato can run the test with the same config.

couple things
when you have multiple line breaks in a single command, you need \ to indicate the line continues; see our example https://github.com/linuxserver/docker-couchpotato#docker-cli

you’re putting a web url in there and it’s asking you for an RPC connection; just put the ip and port

let us know if that works for you :slight_smile:

thank you … I think I erred when I cut and paste the cli. This is what I had (see below) I tried the 8090 port in the end just because I know that’s what utorrent uses. But I think that’s just meant for couchpotato, not for what couchpotato is talking to.

> sudo docker create --name=couchpotato \
> --restart=always \
> -v /home/docker/couchpotato/config:/config \
> -v /home/docker/couchpotato/downloads:/downloads \
> -v /Windows/Natasha/Movies:/movielink \        
> -e PGID=1001 -e PUID=1001 \
> -e TZ=Europe/London \
> -p 5050:5050 \
> -p 8090:8090 \                                                 
> linuxserver/couchpotato

also … tried removing the http but I believe it prefers it. I have another server running couchpotato that is not docked that runs the test just fine with the http.

So I guess the big question is… do I have to do something special with the ports here? or is something else going on and my docker is ok. Couchpotato is definitely running perfectly, it just cannot talk to utorrent for whatever reason. But i can ping it … so that’s something?

(heres the couchpotato log but looks evil and confusing)

10-26 00:45:22 ERROR
[ couchpotato.api] Failed doing api request “download.qbittorrent.test”: Traceback (most recent call last): File “/app/couchpotato/couchpotato/api.py”, line 36, in run_handler res = apiroute File “/app/couchpotato/couchpotato/core/base/downloader/main.py", line 179, in test t = self.test() File "/app/couchpotato/couchpotato/core/downloaders/qbittorrent.py", line 46, in test return self.connect() File "/app/couchpotato/couchpotato/core/downloaders/qbittorrent.py”, line 35, in connect self.qb = QBittorrentClient(url) File “/app/couchpotato/libs/qbittorrent/client.py”, line 17, in init check_prefs = session.get(url+‘query/preferences’) File “/app/couchpotato/libs/requests/sessions.py”, line 481, in get return self.request(‘GET’, url, **kwargs) File “/app/couchpotato/libs/requests/sessions.py”, line 469, in request resp = self.send(prep, **send_kwargs) File “/app/couchpotato/libs/requests/sessions.py”, line 577, in send r = adapter.send(request, **kwargs) File “/app/couchpotato/libs/requests/adapters.py”, line 413, in send raise ConnectionError(err, request=request) ConnectionError: (‘Connection aborted.’, error(113, ‘Host is unreachable’))

you’re using the qbittorrent thing to try to setup utorrent… that’s not going to work. If you dont see one for utorrent, you won’t be able to use utorrent with cp. we have a qbittorrent container if you’d like to try it out.

yeah that’s my bad… I used utorrent for years and I keep saying utorrent instead of qbittorrent. Everytime I say utorrent (even in the title) I mean qbittorrent. Thanks for helping though, that obviously would be a problem.

I’m actually giving up and using radarr, which connects to qbittorrent just fine.

gotcha, i made the swap from cp to radarr as well, as much as I hate mono, it just worked better tbh.