Dokuwiki container does not work after update

I hope somebody can help me out.

I used the Dokuwiki container (19.03.8 sha3 …CF97) for quite some time.
Setup was done with a shell script using docker create, without specified version.
confg/data in a host directory. Shell script specifies uid/gid which matches permissions of the directory on the host.

Removed the container and image, executed the same shell script (so nothing changed, just a newer version: “latest” )

The container log ends with this:

Go to http://IP-ADDRESS:PORT/install.php to configure your install then restart your container when 
finished to remove install.php
[cont-init.d] Setting permissions this may take some time
[cont-init.d] 50-config: exited 0.
[cont-init.d] 99-custom-files: executing... 
[custom-init] no custom files found exiting...
[cont-init.d] 99-custom-files: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

Container is running, but Dokuwiki is unreachable.

I am relatively new to Docker, so any directions where to look would be appreciated.

Note: I could not find a appropriate tag for this topic.

Could you post the shell script? I assume this is something you created as this isn’t something we provide.

The shell script just contains the create command:

docker create \
  --name=dokuwiki \
  -e PUID=1000 \
  -e PGID=1000 \
  -e TZ=Europe/London \
  -e APP_URL=/dokuwiki `#optional` \
  -p 380:80 \
  -p 343:443 `#optional` \
  -v /mnt/md0/repos/docuwiki/config:/config \
  --restart unless-stopped \

And what url are you trying to connect to dokuwiki?

I tried the one I bookmarked:

As well as:

I Just tried the same script, but now pointing to an empty directory instead of the existing config directory. Then the URL is accessible, so it seems to have something to do with the version difference.

After this I copied the “fresh” install config over the existing config, after which is was running as expected without loosing any data :grinning:

So it seems afterall not a container issue, but related to the different versions, but thanks for your help.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.