Domoticz, add correct socket capabilities on domoticz binary


I just moved to domoticz container instead of a classic server install.

I run the container with -e PUID=1000 -e PGID=1000 to run it as non root user and I noticed the ping plugin I have before, stopped working.

In domoticz wiki, here

A note for non root at the end of the page says socket capability must be added to the executable.

So I tried do add it:

$ setcap cap_net_raw=+eip /var/lib/domoticz/domoticz

And restarted the container but capability seems to be lost when container restarts.

How can the capability can be added ?

As far as I know, pinging using non root user was fixed a couple of months ago.
I guess you might be running one of the stable tags and not latest?
Iputils is added in latest and the stable tag. So ping should work.

No, I’m using latest tag.
But the issue is not about the ping command.
This one actually working.

The issue is about domoticz binary itself, witch doesn’t seems to have the socket capability.
It doesn’t use the command line ping
So python plugins get error, operation not permitted.

I didn’t know it didn’t use the command line ping.
I’ll look into adding the correct capabilities for domoticz.

It should be fixed now. Might take some hours before it shows on dockerhub as it’s a slow build.

Yes, I confirm, the issue is fixed, now ping from domoticz is working.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.