Domoticz container installs but it's not accessible

To clarify, “optional” comments in docker run/create and docker compose yamls are fine as long as the samples in the readme are followed (we make sure that they are ignored properly).

But that’s not the case for any gui entry like omv docker plugin

1 Like

Thanks ffor the help all of you guys!
It worked just by completely removing the WEBROOT entry from the environmental parameters.

I have one last question.
I got the OpenZwave USB stick by Aeotec. Where do I have to enter the extra parameters for it to be recognized by the system?

Environmental or extra?

Many thanks

Never mind. I got it to work but after a while the openzwave stick stopped interacting with the smart sockets.

The log reports that there is a problem with communication with the OpenZWave USB module.

2019-08-13 19:16:50.815 Error, Node011, ERROR: ZW_SEND_DATA could not be delivered to Z-Wave stack
2019-08-13 19:16:50.815 Always,
2019-08-13 19:16:50.815 Always, Dumping queued log messages
2019-08-13 19:16:50.815 Always,
2019-08-13 19:16:50.816 Always,
2019-08-13 19:16:50.816 Always, End of queued log message dump
2019-08-13 19:16:50.816 Always,
2019-08-13 19:16:50.817 Error, Node011, ERROR: Dropping command, expected response not received after 6 attempt(s)
2019-08-13 19:16:50.817 Always,
2019-08-13 19:16:50.817 Always, Dumping queued log messages
2019-08-13 19:16:50.817 Always,
2019-08-13 19:16:50.818 Always,
2019-08-13 19:16:50.818 Always, End of queued log message dump
2019-08-13 19:16:50.818 Always,
2019-08-13 19:16:50.918 Status: OpenZWave: All Nodes queried (Some Dead)

Can anyone please specify what is the format of the extra parameters?
I’m trying to reset the container from scratch and I’m failing to insert my Zwave USB stick /dev/ttyACM0

Any help would be greatly appreciated.

Should it be --device /dev/ttyACM0
or --device /dev/ttyACM0:/dev/ttyACM0
or ----device /dev/ttyACM0 ?

Thanks!

Did you look at the Readme on github? It’s described there.

–device /dev/ttyACM0:/dev/ttyACM0

1 Like

I did. The problem is that I’m fairly sure the line wasn’t that long last time I got it working because as I stated, I had this working OK for a couple of months.

Many thabks

I’m still unable to get this working.
ls -l /dev/ttyUSB* reports:
lrwxrwxrwx 1 root root 7 Jan 27 13:24 /dev/ttyUSB-ZStick-5G -> ttyACM1

So which of the 2 I have to use?
/dev/ttyUSB-ZStick-5G
or
/dev/ttyACM1 ?

I’ve tried both and only the first one is accepted but I can’t find my USB working within Domoticz.
The second returns an error like:

Failed to execute command ‘export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C.UTF-8; docker run -d --restart=unless-stopped -v /etc/localtime:/etc/localtime:ro --net=bridge -p 0.0.0.0:8090:8080/tcp -p 0.0.0.0:6144:6144/tcp -p 0.0.0.0:1443:1443/tcp -e PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" -e PS1="$(whoami)@$(hostname):$(pwd)$ " -e HOME="/config" -e TERM=“xterm” -e PUID=“1000” -e PGID=“100” -e TZ=“Europe/London” -v “/sharedfolders/AppData/Domoticz”:"/config":rw --name=“domoticz” --label omv_docker_extra_args="–device /dev/ttyACM1:/dev/ttyACM1" –device /dev/ttyACM1:/dev/ttyACM1 “linuxserver/domoticz:latest” 2>&1’ with exit code ‘125’: docker: invalid reference format. See ‘docker run --help’.

You need to make sure that the user you map in PUID and PGID have the right permissions for the usb device you are using.
Now it’s only root that have access. So change the permissions and it shouldn’t matter which of the two names you use.

1 Like

It seems I got it working again by inputting the whole line like you indicated above. This time the container started normally without errors and I can now initialize my USB stock and even add one plug. There is a serious delay in communication between the stick and the plug but that’s probably due to some other reason.

I have one last question: Whenever I plug and unplug the Aeotec Stick, it will get either /dev/ttyAMC0 or /dev/ttyAMC1.
I want to make it persistent /dev/ttyAMC0 so that I will be able to plug and unplug it without problems.

I don’t know how to make the device getting the same device name. This is not a container issue, but host issue so The almighty Google probably have an answer for that.

I haven’t unplugged my zwave usb since I installed it, so unsure why you need to?

1 Like

I need to plug and unplug in order to pair smart devices with the Aeotec stick.

Thanks anyway.

I have the same device here and I never needed to remove it to add devices.

1 Like

But how?
The manual says it has to be unplugged and its button to be pressed once to get in pairing mode (blue led flashing slowly) and then get it close in proximity to the target device.

What am I missing after all?

You add the devices in Domoticz.
Go to Setup --> Hardware --> Setup on the Zwave stick.
In the top right corner you have a button that says node managment. Cliking that drops down a menu and you can choose Include node (Or include secure node). Click the button and go to the device you want to include and push the include button or sequence for that device. It should then pop up that new device is found.

1 Like

Thank you!

I’ll try this method first thing when I’m back home.

Thank you so much for helping out with this.
I indeed got to pair the usb stick with all my nodes the way you suggested.

My other problem now is that I can’t add the RFXCOM transceiver aside the Z-Wave controller.

In the extra-arguments field, how am I supposed to enter both values?
I tried:

–device /dev/ttyACM0:/dev/ttyACM0 && --device /dev/ttyUSB0:/dev/ttyUSB0

seperating those 2 with ‘’&&’’ or a ‘’:’’ or even a ‘’,’’ but nothing seems to work as the configuration / modification cannot be saved.

You don’t have to add anything between them.

1 Like

I was that easy after all! I got it working at last. Thank you.Your help is always valuable!