Duckdns - Initial configuration issue

There isn’t a great deal to configure in this container, so unsure where I am going wrong. I know the token is correct as I have copied/pasted from the duckdns.org site.

Edit - Working…ish

It works if I remove the UPDATE_IP variable. Seems my network doesn’t like using Cloudflare for some reason?

“Omitting the UPDATE_IP variable uses DuckDNS for detection and only supports IPv4.”

docker-compose:

  duckdns:
    image: lscr.io/linuxserver/duckdns:latest
    container_name: duckdns
    network_mode: host
    environment:
      - SUBDOMAINS=thiswillbedeleted
      - TOKEN=REMOVED
      - UPDATE_IP=ipv4
      - LOG_FILE=false
    restart: unless-stopped

When starting the container, I get the following…

[migrations] started
[migrations] no migrations found
usermod: no changes
───────────────────────────────────────

      ██╗     ███████╗██╗ ██████╗
      ██║     ██╔════╝██║██╔═══██╗
      ██║     ███████╗██║██║   ██║
      ██║     ╚════██║██║██║   ██║
      ███████╗███████║██║╚██████╔╝
      ╚══════╝╚══════╝╚═╝ ╚═════╝

   Brought to you by linuxserver.io
───────────────────────────────────────

To support the app dev(s) visit:
DuckDNS: https://www.patreon.com/user?u=3209735

To support LSIO projects visit:
https://www.linuxserver.io/donate/

───────────────────────────────────────
GID/UID
───────────────────────────────────────

User UID:    911
User GID:    911
───────────────────────────────────────

Detecting IPv4 via CloudFlare
curl: (3) URL rejected: Malformed input to a URL function
Something went wrong, please check your settings Mon Feb  5 11:15:28 UTC 2024
The response returned was:

[custom-init] No custom files found, skipping...
[ls.io-init] done.