Error when using headphones docker image with https://

headphones

#1

Hi,

I installed the headphones docker image on my Debian, and in config.ini file, I enabled https via “https_enabled” option in config.ini file. The docker image is launched with no extra configuration than the one provided in its documentation (port 8181, volumes, etc…)

But when I want to launch the site, via “https://my.domain.com/headphones:8181”, I get the following error message : “The client sent a plain HTTP request, but this server only speaks HTTPS on this port.”. If I disable https, it runs fine.

Do you have an idea to solve this problem ?

Thanks


#2

The image doesn’t have SSL built-in. It is recommend to put your services behind a reverse proxy like our letsencrypt container for example.