How to make DLNA work in Jellyfin with Swag?

Hi, I am trying to get the jellyfin container DLNA service to work in reverse proxy with swag but I am not able to. In principle, I created a network in bridge mode for swag and jellyfin but since it is not on the host network, the devices do not discover the DLNA.

I also tried creating a macvlan for jellyfin but even though the devices discover DLNA, I can’t move forward in the movies (it seems like jellyfin thinks the device is off the local network and transcodes)
I’ve tried adding local ips ranges but it doesn’t work either, what could I do?
Sorry for my english. Thanks.

The parameters used for swag and jellyfin and the macvlan:

sudo docker create \
  --name=swag \
  --cap-add=NET_ADMIN \
  --net=lsio \
  -e PUID=1000 \
  -e PGID=1000 \
  -e TZ=Europe/Madrid \
  -e URL=mydomain \
  -e SUBDOMAINS=wildcard \
  -e VALIDATION=duckdns \
  -e DUCKDNSTOKEN=mytoken \
  -p 443:443 \
  -p 80:80 \
  -v /home/me/appdata/swag:/config \
  --restart unless-stopped \
 ghcr.io/linuxserver/swag


sudo docker run -d \
      --name=jellyfin \
      --net=home-net \
      --ip=192.168.1.10 \
      --mac-address=02:42:c0:a8:01:0f \
      -e PUID=1000 \
      -e PGID=1000 \
      -e TZ=Europe/Madrid \
      -e JELLYFIN_PublishedServerUrl=192.168.1.10 `#optional` \
      -p 8096:8096 \
      -p 8920:8920 `#optional` \
      -p 7359:7359/udp `#optional` \
      -p 1900:1900/udp `#optional` \
      -v /home/me/appdata/jellyfin:/config \
      -v /mnt/hdd/tv:/data/tvshows \
      -v /mnt/hdd/films:/data/movies \
      --device /dev/dri:/dev/dri `#optional` \
      --restart unless-stopped \
  ghcr.io/linuxserver/jellyfin


docker network create -d macvlan --subnet=192.168.1.0/24 --gateway=192.168.1.1 -o parent=eno1 home-net
1 Like

Second EDIT: just in case anyone else has this issue, look at this part in the proxy config:


## Version 2021/05/18
# make sure that your dns has a cname set for jellyfin
# if jellyfin is running in bridge mode and the container is named "jellyfin", the below config should work as is
# if not, replace the line "set $upstream_app jellyfin;" with "set $upstream_app <containername>;"
# or "set $upstream_app <HOSTIP>;" for host mode, HOSTIP being the IP address of jellyfin
# in jellyfin settings, under "Advanced/Networking" change the public https port to 443, leave the local ports as is,
# and set the "Secure connection mode" to "Handled by reverse proxy"

The secure connection mode isn’t needed anymore so that should be updated in the proxy configs but everything else solves this issue. Pieced this together from talking with folks from JF in their matrix room and from a post on the LSIO discord I found when searching for DLNA.

EDIT- just realized that was you that posted on reddit too :stuck_out_tongue:
I am in the same situation as you.
There are old issues that people mention but no clear solutions.