How to set the base url for ubooquity?


Recently I succeeded to implement ubooquity behind swag, for domain I set it as subdomain, it likes, it looks good, but there have a problem, when I open a book in library, the browser link jump into, and the port disappear in the link, and the browser can not open the book. I have to manually add the port back into the browser link, so it could open the book now.

For this kind of circumstance, I know there should have a solution, which defined the base url to tell server software jumped base the address and port, I tried to google it, but I can’t find out this kind of setting for ubooquity, Does someone know about it, thanks!

You are not using the reverse proxy if you specify port. That is way it’s not working. Ubooquity doesn’t know anything about the port and removes it from the URL.
So you should look at your reverse proxy.

So check that your ubooquity container has the same name as the upstream_app in the proxy conf, that both swag and ubooquity is in the same docker network, not the default network if you are using anything else than compose and that you have not modified the port in the proxy conf.

Due to my ISP blocked 443 port, so I have to use other opened port and forward it to 443, so that means you can see I used self-defined port in the link.
Here is a sample when I tried to implement dokuwiki. I defined the baseurl and it works.


I tried to find a way similar with it.