I can't figure out swag-auto-uptime-kuma

I came across swag-auto-uptime-kuma the other day and I have been trying to get it to work. I’m not getting any errors but it’s also not doing what I expected. I used an old computer to test, put a fresh install of Ubuntu and Docker on it and then created this docker-compose.yml file which is pretty much identical to the Swag with CloudFlare example on the website.

services:
  swag:
    image: lscr.io/linuxserver/swag
    container_name: swag
    cap_add:
      - NET_ADMIN
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/London
      - URL=my.cloud
      - VALIDATION=dns
      - SUBDOMAINS=wildcard
      - DNSPLUGIN=cloudflare
   #  - DOCKER_MODS=linuxserver/mods:swag-dashboard|linuxserver/mods:swag-auto-uptime-kuma|linuxserver/mods:swag-auto-proxy|linuxserver/mods:universal-docker|linuxserver/mods:universal-cloudflared
      - DOCKER_MODS=linuxserver/mods:swag-dashboard|linuxserver/mods:swag-auto-proxy|linuxserver/mods:universal-docker|linuxserver/mods:universal-cloudflared
      - DOCKER_HOST=tcp://dockerproxy:2375
      - UPTIME_KUMA_URL=http://uptime-kuma:3001/
      - UPTIME_KUMA_USERNAME=steve
      - UPTIME_KUMA_PASSWORD=Removed
      (Cloudflare stuff removed)
      - FILE__CF_TUNNEL_CONFIG=/config/tunnelconfig.yml
    extra_hosts:
      - my.cloud:127.0.0.1
    volumes:
      - /docker/swag:/config
    restart: unless-stopped

  uptime-kuma:
    image: louislam/uptime-kuma:1
    container_name: uptime-kuma
    volumes:
      - /docker/uptime-kuma-data:/app/data
    ports:
      - 3001:3001  
    restart: always

  dockerproxy:
    image: ghcr.io/tecnativa/docker-socket-proxy
    container_name: dockerproxy
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock:ro
    environment:
      - CONTAINERS=1
      - POST=0
    labels:
      - swag=enable
    restart: unless-stopped

  overseerr:
    image: lscr.io/linuxserver/overseerr
    container_name: overseerr
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/London
    volumes:
      -  /docker/overseerr:/config
    labels:
      - swag=enable
      - swag.uptime-kuma.enabled=true
      - swag.uptime-kuma.monitor.name=Overseerr
      - swag.uptime-kuma.monitor.url=https://overseerr.my.cloud

    restart: unless-stopped

This comes up absolutely fine - not an error in sight - and uptime-kuma.my.cloud and overseerr.my.cloud are instantly accessible when Swag displays “Server Ready” but my expectation - that overseerr would appear as a monitor in uptime-kuma doesn’t happen.

I’ve only found two other posts about swag-auto-uptime-kuma - one of them unanswered and the other was a problem with reading secrets with a file.

Does anyone have a working example? I’m going to guess it’s the labels I’ve used due to the lack of any helpful messages in the logs - they’re wrong but just being ignored.

Thanks

Steve