Inital SWAG setup with http validation fails

Hi All,

I’ve recently started exploring using docker so some of this is all new to me, I’m trying to set this up for the first time.

I have a domain registered with a subdomain where the CNAME (test.<MY_DOMAIN>) is pointing to duckDNS (<MY_DUCKDNS>, and a container updating duckDNS regularly.

I have the letsencrypt container running with a compose file and I’m trying to use http validation
In my compose file I have set


I get the following error in the log


  • The following errors were reported by the server:
    Domain: test.<MY_DOMAIN>
    Type: connection
    Detail: Fetching
    Connection refused


  1. Is there another step to get http validation working?
    • I failed to find a “.well-known/_acme-challenge” folder with my limited knowledge of nxgen
  2. Is this supposed to be a folder I can explore by command line or is it hooked up with some other means?

Note: If there is a better way to get my domain name to work with duck dns i’d like to know, it sounded the the duck dns options for swag were meant specifically to use the duckdns name and not a domain that is pointed to duckDNS.

You won’t find a folder. Certbot puts up its own webserver during http validation and serves those temp files.

If http validation is failing, your issue is likely IP/dns or port forward related.

See here:

Thanks for the explanation and the link.
I restarted my entire setup and followed those instructions and got it all working.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.