Jackett blank page after starting successfully

im trying to run the latest jackett image on ubuntu 18.04 LTS.

the problem is that, even though jackett seems to start fine, im getting no response (blank page, 0kb response without response code) when trying to access jackett.

log:

log.txt

config files:

ServerConfig.json:

{
  "Port": 9117,
  "AllowExternal": true,
  "APIKey": "par2wov5l3nkhi96rdz3dfsx0ddxr4bq",
  "AdminPassword": null,
  "InstanceId": "je6z5rt3b2527pyqukve8fw1wrb4xrpfnzlv0zmi07jdas905tqlil2j1bdre7xi",
  "BlackholeDir": null,
  "UpdateDisabled": false,
  "UpdatePrerelease": false,
  "BasePathOverride": null,
  "OmdbApiKey": null,
  "OmdbApiUrl": null,
  "ProxyUrl": null,
  "ProxyType": 0,
  "ProxyPort": null,
  "ProxyUsername": null,
  "ProxyPassword": null,
  "ProxyIsAnonymous": true
}

appsettings.json:
{ "urls": "http://0.0.0.0:9117" }

docker-compose.yaml

version: '3'
jackett:
    container_name: jackett
    image: linuxserver/jackett
    ports:
      - "127.0.0.1:9117:9117"
    networks:
      - main
    environment:
      - PUID=1000
      - PGID=1000
      - TZ=Europe/Berlin
      - RUN_OPTS="-t -l"
    volumes:
      - /.../jackett/config/:/config
      - /.../jackett/downloads/:/downloads

networks:
  main:

am i missing anything? i dont even get a response using curl from within the container, which means that jackett itself is not serving any content.

I originally posted this on the jackett github, but i have been redirected here since they couldn’t help me.
i hope that pretty much copy-pasting this from github is okay.
original issue: https://github.com/Jackett/Jackett/issues/6690

can you share your docker run/compose

have edited it in the original post, thanks for the reminder

no worries, first thing is this line; this should JUST be ports, please change to - 9117:9117

next, this curl test, my jackett works fine, via webbrowser, but curl returns nothing at all. not sure why, but i’d say it’s not a valid test method for jackett.

I’m not familiar with your RUN_OPTS, so i can’t speak to those.

Your volumes … did you actually create a folder called ... ?

Our ServerConfig.json are the same (key and id are diff ofc) and I dont have an appsettings.json at all. for testing, i would move that app json into a tmp folder, remove the RUN_OPTS, and fix that port config, then test. After a few minutes (give it time to do “things”) you should be able to browse to http://<docker host ip>:9117

Like i mentioned, curl returned nothing for me, but i can browse to it fine. Let me know how this goes!

the ports line with ip is perfectly valid in docker, see: https://docs.docker.com/config/containers/container-networking/#published-ports

i added a IP here to be able to reverse proxy without also making the page avaliable on my server ip. it works well with all my other containers, like the linuxserver/heimdall container im also running.

i shortened the volume path because it was rather long, im sorry i should have made that clear.

i have added the appsettigns.json after reading the logs and noticing that jackett was binding itself to [::]:9117 which is a ipv6 ip.

in the end it turns out that the issue was excatly that, curl doesn’t show the page html like it does for other pages, whihc lead me to belive that jackett wasnt servign anything, even though it was my reverse proxy which was misconfigured. my fault entirely.

the curl thing was definitely weird, i tested it against a few of my apps and jackett was the only one to return nothing… the rest didnt return much, but there was something. It sounds like you’ve got it working now though after tweaking your reverse proxy? if yes, happy for you! if no, i’m out of thoughts and we’ll need someone more experienced :frowning:

also in terms of that IP in line with ports WOW, i actually read that link before noting it was wrong, then when you corrected me i checked again and both times i didn’t even see the line… man im blind (and old) but hey, TIL and i thank you for that!

yes i got it working,

i accepted your prior response as solved didnt i?

yeah, that ip in port mapping is usefull for limiting access to the service to localhost. and yeah, curl works for other apps so i assumed it would for jackett too, but even when i added the complete path to the url (not relying on redirect) it showed nothing.

ah you did, sorry im new to discourse, didnt even notice the accepted thing. Yah I tried curling jackett in various ways with no results. I did find that curling the rss feed link will return results, but that’s about it. very interesting.

anyway, take care glad you got it fixed!

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.