Jellyfin on microk8s with hw transcoding

So I’m trying to get the image to run with hw transcoding support on microk8s. Looks as if it’s not possible to explicitly pass in a /dev on a node in k8s.

Microk8s have it’s own set of gpu daemonset you can enable with ‘microk8s enable gpu’. The pass in a gpu by using a resource/limit/ 1 setting. But alas,doesn’t seem tot do anything.

Anyone got experience in this, is there a workaround or is it only possible to run on docker with hw transcoding?

best bet is to ask in #other-support on our discord. None of the team tests this stuff on K8s, micro or otherwise.

1 Like