Just installed openvpn-as can't login as admin

I just installed Openvpn in a Portainer docker. (OpenmediaVault 5)
Install went smoothly, no errors, I can go to the https://IP:943 and login with the default admin/password and it displays the recommended setups for my device, but when I try to log into the Admin portal on https://IP:943/admin it gives me this error:

" SESSION ERROR: SESSION: Your session has expired, please reauthenticate (9007) "

I have deleted and re-setup the docker, verified the settings on the docker hub, and have the same issue…
After much googling, and searching, I can’t find an answer that fits closely to my situation, so I am turning to this forum.

Any help would be appreciated… Thank you.

are you able to replicate the issue without using portainer?

also, did you ensure you set the authentication to local instead of PAM during initial login as well as modifying the as.conf file after creating a new user?

never got past the initial login… received this error when attempting initial login

ok, can you try to replicate the issue without portainer, i just tested locally with no issues but I don’t use portainer. Portainer could be the issue.

That error happens when either of the following occurs:

  1. iptables issues on host (either not installed or missing kernel modules)
  2. you didn’t add cap-add NET_ADMIN
  3. you’re using an unsupported networking method (host or macvlan)


I had added the cap-add NET_ADMIN, in the commands section in Portainer.
BUT this is not how Portainer handles this apparently.
Under Advanced Container Settings - CAPABILITIES tab there is a toggle switch for NET ADMIN that does this.

This is my first time using Portainer, so I didn’t realize where to look.

Thank you so much for the help!

I hit this problem yesterday. For me, I’d managed to typo the container name in my nginx proxy config - both the “/admin” and “/” routes need to be configured correctly to be able to log in to the admin page.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.