Kasm subpath reverse proxy issue

I’m trying to use remmina and set reverse proxy with nginx.
Here’s the docker compose yaml

name: remmina
    image: lscr.io/linuxserver/remmina:latest
    container_name: remmina
      - PUID=1000
      - PGID=1000
      - TZ=Etc/UTC
      # reverse proxy
      - SUBFOLDER=/remmina/
      - ~/docker-data/remmina:/config
      - 3100:3000
    restart: unless-stopped

Here’s part of nginx conf

    location /remmina/{
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";   

After setting these up, access my.domain/remmina/ ends up with title Error and content Cannot GET /
I tried to modify the nginx conf location /remmina/ to location /remmina, the kasmvnc shows up but failed to load, console shows it tries to access my.domain/websockify.
I googled it and found the kasm don’t support subpath rp, (18) Setting Kasm to Nginx subdirectory? : kasmweb (reddit.com), so is this my configuration wrong or the document?

1 Like

i raised issue

still no outcome

thanks for your reply, i had moved on and found a project that supports subpath (GitHub - jlesage/docker-baseimage-gui: A minimal docker baseimage to ease creation of X graphical application containers) , the author also build a docker firefox based on this so you can try it out https://hub.docker.com/r/jlesage/firefox