kodi-headless:Leia 100% cpu usage

kodi-headless

#1

Started the container as both a fresh install and as an upgrade to Krypton, CPU usage quickly jumps to 100%. It looks like the culprit is something to do with the Xorg/xpra. I’ve let it run for 15 minutes and the CPU usage never comes down. The only thing that ends up in the /config/.kodi directory is the advancedsettings.xml file. The container starts normally with either the latest or kyrpton tags. Any help would be appreciated.

From top command:

top - 08:44:38 up 18 days, 12:12,  0 users,  load average: 2.36, 2.51, 2.08
Tasks:   8 total,   2 running,   6 sleeping,   0 stopped,   0 zombie
%Cpu(s): 45.8 us,  4.5 sy,  0.0 ni, 49.3 id,  0.3 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem :  4048352 total,   274032 free,  1688592 used,  2085728 buff/cache
KiB Swap:        0 total,        0 free,        0 used.  1761192 avail Mem

   PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND 
  2026 nobody    20   0   92884   9184   7052 R  91.0  0.2   0:02.74 Xorg 
  2023 nobody    20   0   82272  16708   8108 S   1.3  0.4   0:00.04 xpra  
   584 root      20   0   40348   3552   3104 R   0.3  0.1   0:00.09 top    
     1 root      20   0     200      4      0 S   0.0  0.0   0:00.02 s6-svscan   
    30 root      20   0     200      4      0 S   0.0  0.0   0:00.00 s6-supervise  
   204 root      20   0     200     68     48 S   0.0  0.0   0:00.10 s6-supervise  
   577 root      20   0   20176   3696   3372 S   0.0  0.1   0:00.01 bash 
  2021 root      20   0   20044   3480   3224 S   0.0  0.1   0:00.00 bash

From the Xorg.:100.log:

[1599686.125] _XSERVTransmkdir: Owner of /tmp/.X11-unix should be set to root
[1599686.129] 
X.Org X Server 1.19.6
Release Date: 2017-12-20
[1599686.129] X Protocol Version 11, Revision 0
[1599686.129] Build Operating System: Linux 4.4.0-138-generic x86_64 Ubuntu
[1599686.129] Current Operating System: Linux b5e9685586ba 4.9.75-rancher #1 SMP Sat Jan 6 00:16:10 UTC 2018 x86_64
[1599686.129] Kernel command line: console=ttyS0 BOOT_IMAGE=/boot/vmlinuz-4.9.75-rancher rancher.password=buffoonz3 printk.devkmsg=on rancher.state.dev=LABEL=RANCHER_STATE rancher.state.wait rancher.resize_device=/dev/sda
[1599686.129] Build Date: 25 October 2018  04:11:27PM
[1599686.129] xorg-server 2:1.19.6-1ubuntu4.2 (For technical support please see http://www.ubuntu.com/support) 
[1599686.129] Current version of pixman: 0.34.0
[1599686.129] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[1599686.129] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[1599686.129] (++) Log file: "/tmp/Xorg.:100.log", Time: Sun Feb 17 08:53:48 2019
[1599686.129] (++) Using config file: "/etc/xpra/xorg.conf"
[1599686.129] (EE) Unable to locate/open config directory: "/config/.xpra/xorg.conf.d"
[1599686.129] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[1599686.133] (==) ServerLayout "dummy_layout"
[1599686.133] (**) |-->Screen "dummy_screen" (0)
[1599686.133] (**) |   |-->Monitor "dummy_monitor"
[1599686.137] (**) |   |-->Device "dummy_videocard"
[1599686.137] (**) Option "DontVTSwitch" "true"
[1599686.137] (**) Option "AllowMouseOpenFail" "true"
[1599686.137] (**) Option "AutoAddDevices" "false"
[1599686.137] (**) Option "AutoEnableDevices" "false"
[1599686.137] (**) Not automatically adding devices
[1599686.137] (**) Not automatically enabling devices
[1599686.137] (==) Automatically adding GPU devices
[1599686.137] (==) Automatically binding GPU devices
[1599686.137] (==) Max clients allowed: 256, resource mask: 0x1fffff
[1599686.137] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
[1599686.137] 	Entry deleted from font path.
[1599686.137] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[1599686.137] 	Entry deleted from font path.
[1599686.137] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[1599686.137] 	Entry deleted from font path.
[1599686.137] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[1599686.137] 	Entry deleted from font path.
[1599686.137] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[1599686.137] 	Entry deleted from font path.
[1599686.137] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[1599686.137] 	Entry deleted from font path.
[1599686.137] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[1599686.137] 	Entry deleted from font path.
[1599686.137] (==) FontPath set to:
	built-ins
[1599686.137] (==) ModulePath set to "/usr/lib/xorg/modules"
[1599686.137] (==) |-->Input Device "<default pointer>"
[1599686.137] (==) |-->Input Device "<default keyboard>"
[1599686.137] (==) The core pointer device wasn't specified explicitly in the layout.
	Using the default mouse configuration.
[1599686.137] (==) The core keyboard device wasn't specified explicitly in the layout.
	Using the default keyboard configuration.
[1599686.137] (II) Loader magic: 0x55d50d57e020
[1599686.137] (II) Module ABI versions:
[1599686.137] 	X.Org ANSI C Emulation: 0.4
[1599686.137] 	X.Org Video Driver: 23.0
[1599686.137] 	X.Org XInput driver : 24.1
[1599686.137] 	X.Org Server Extension : 10.0
[1599686.137] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)
[1599686.137] (II) no primary bus or device found
[1599686.137] (II) LoadModule: "glx"
[1599686.137] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[1599686.141] (II) Module glx: vendor="X.Org Foundation"
[1599686.141] 	compiled for 1.19.6, module version = 1.0.0
[1599686.141] 	ABI class: X.Org Server Extension, version 10.0
[1599686.141] (II) LoadModule: "dummy"
[1599686.141] (II) Loading /usr/lib/xorg/modules/drivers/dummy_drv.so
[1599686.141] (II) Module dummy: vendor="X.Org Foundation"
[1599686.141] 	compiled for 1.19.3, module version = 0.3.8
[1599686.141] 	Module class: X.Org Video Driver
[1599686.141] 	ABI class: X.Org Video Driver, version 23.0
[1599686.141] (II) LoadModule: "mouse"
[1599686.141] (WW) Warning, couldn't open module mouse
[1599686.141] (II) UnloadModule: "mouse"
[1599686.141] (II) Unloading mouse
[1599686.141] (EE) Failed to load module "mouse" (module does not exist, 0)
[1599686.141] (II) LoadModule: "kbd"
[1599686.141] (WW) Warning, couldn't open module kbd
[1599686.141] (II) UnloadModule: "kbd"
[1599686.141] (II) Unloading kbd
[1599686.141] (EE) Failed to load module "kbd" (module does not exist, 0)
[1599686.141] (II) DUMMY: Driver for Dummy chipsets: dummy
[1599686.141] (WW) Falling back to old probe method for dummy
[1599686.141] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[1599686.141] (II) DUMMY(0): Chipset is a DUMMY
[1599686.141] (++) DUMMY(0): Depth 24, (--) framebuffer bpp 32
[1599686.141] (==) DUMMY(0): RGB weight 888
[1599686.141] (==) DUMMY(0): Default visual is TrueColor
[1599686.141] (==) DUMMY(0): Using gamma correction (1.0, 1.0, 1.0)
[1599686.141] (DB) xf86MergeOutputClassOptions unsupported bus type 0
[1599686.141] (**) DUMMY(0): VideoRAM: 256000 kByte
[1599686.141] (**) DUMMY(0): Max Clock: 600000 kHz
[1599686.141] (II) DUMMY(0): dummy_monitor: Using hsync range of 1.00-2000.00 kHz
[1599686.141] (II) DUMMY(0): dummy_monitor: Using vrefresh range of 1.00-200.00 Hz
[1599686.141] (II) DUMMY(0): Clock range:  11.00 to 600.00 MHz
[1599686.141] (II) DUMMY(0): Not using mode "7680x4320" (height too large for virtual size)
[1599686.141] (II) DUMMY(0): Not using default mode "320x180" (bad mode clock/interlace/doublescan)
[1599686.141] (II) DUMMY(0): Not using default mode "320x180" (bad mode clock/interlace/doublescan)
[1599686.141] (II) DUMMY(0): Not using default mode "360x202" (bad mode clock/interlace/doublescan)
[1599686.141] (II) DUMMY(0): Not using default mode "1368x768" (monitor doesn't support reduced blanking)
[1599686.141] (II) DUMMY(0): Not using default mode "15360x8640" (insufficient memory for mode)
[1599686.141] (II) DUMMY(0): Not using default mode "15360x8640" (insufficient memory for mode)

#2

See here: https://github.com/linuxserver/docker-kodi-headless/issues/87


#3

That sucks… Thanks though


#4

Check out latest Leia image.