webtop access outside system?


I am at wits’ end trying to get to work behind a reverse proxy.

I posted about this with extensive details on reddit and on Caddy’s forum.

I am trying to set up webtop to serve internally to a Caddy reverse proxy. Caddy is not run via Docker but I am more and more convinced that Caddy is not the issue.

I go into extensive details with what I tried on the Caddy side in those posts but I will focus on the Docker side here.

My Docker-Compose is below but do note what comes next

version: "2.1"
    container_name: webtop
    privileged: true #optional
      - seccomp:unconfined #optional
      - PUID=1000
      - PGID=1000
      - TZ=America/Denver
      - SUBFOLDER=/ #optional
      - /var/run/docker.sock:/var/run/docker.sock #optional
      - /home/jwinokur/serve/persist:/config #optional
      - 25011:3000
    shm_size: "1gb" #optional

When I run this and go to my website it works. But that is neither secure nor how I want to access it. I want to access it from my Caddy reverse proxy.

I will later change ports to the following but in order to avoid issues, I am, for now, leaving it


Anyway, from my computer, outside Docker, I cannot access it on

$ curl -sSf > /dev/null
curl: (56) Recv failure: Connection reset by peer

And for that matter:

$ curl -sSf > /dev/null
curl: (56) Recv failure: Connection reset by peer

Any ideas? Why can I access the container from the web but not internally? How do I change that so I can set this behind my reverse proxy (outside of the ecosystem).



Webtop wasn’t an option for tags so I used rdesktop since that is probably the closest.