Linuxserver/mods:universal-docker can't find arm version image

Recently I tried to implement CloudFlare with SWAG reverse proxy following guidance of
Zero Trust Hosting and Reverse Proxy via Cloudflare, SWAG and Authelia |
unfortunately the docker mod report “[mod-init] (ERROR) Invalid tarball, could not download linuxserver/mods:universal-docker from
I checked the docker mod in docker hub, it looks like it only has AMD64 version, but don’t have arm64 version.

I’m not sure whether the really problem is the arcch problem or due to the guidance content changed.
I tried to search from internet, but there are don’t have too much information about the topic.
Could someone familiar about it and give me some advice about it, thanks!

Mods aren’t like regular images and we often only have a single arch manfiest pushed to the registries but they all support arm64 unless specifically called out in the mod readme.

You can try setting DOCKER_MODS_DEBUG=true, which will give you slightly more detailed log output, but usually these issues come down either to something blocking your connection to one of the endpoints, or getting rate-limited by Github.

Hi, Thesapad,

Thanks for your comments!

I just read the a bug report in docker-mod in github, there has people with same problems.

I will try the method mentioned in it. then give some feedback about it.

Those threads tend to turn into an amalgamation of a dozen people all with the same symptoms and completely different root causes, which is why it’s rare they ever reach a definitive resolution.

The problems solved by added before original dowload link like below: ```

yes, we suspected your host was the issue, which is why the debug logs were requested, this will indeed bandaid the problem you have though.