Linuxserver/rdesktop Ubuntu versions not working

I am trying to get the Ubuntu versions of linuxserver/rdesktop to work but with limited success. I am using docker-compose running on a Ubuntu 20.04 host and RDPing from another computer (Mac Mini). I have tried creating the container image using the :latest, :ubuntu-mate, :ubuntu-xfce and :ubuntu-kde version tags but so far, only using the :latest version tag has worked.

My docker-compose.yml file is as follows:

version: "2.1"
    container_name: rdesktop
      - seccomp:unconfined
      - PUID=1000
      - PGID=1000
      - TZ=America/Montreal
      - /path/to/data:/config #optional
      - /var/run/docker.sock:/var/run/docker.sock
      - 3389:3389
            #- /dev/dri:/dev/dri #optional
    shm_size: "2gb" #optional
    restart: unless-stopped
    privileged: true

I have tried updating the docker-compose.yml file to use a different version tag, after which I re-run docker-compose to rebuilt the container and try to connect again. When using the :latest version tag, the RDP session connects right away without errors. If I use any of the :ubuntu tags, the behaviour varies and I either get no connection the first time, a black screen which closes on its own, or a black screen that doesn’t update.

I have tried running docker logs -f rdesktop to monitor things and have seen the following:

rdpClientConDeinit: disconnecting clientCon
rdpRemoveClientConFromDev: removing clientCon 0x55af701df5b0
rdpClientConDeinit: deleting file /run/xrdp/sockdir/xrdp_display_10
rdpClientConDeinit: deleting file /run/xrdp/sockdir/xrdp_disconnect_display_10
(II) Server terminated successfully (0). Closing log file.

which appears right before the RDP session window closes. I have also seen what appears to be a segmentation fault message in the logs.

I’ve been able to get the an Ubuntu version of linuxserver/webtop running but would like to get linuxserver/rdesktop working as well with Ubuntu. Any suggestions would be appreciated.