Linuxserver/sabnzbd cannot run script


Docker is a new concept for me and I need some help. I could not find the solution in any forum, tutorial etc. so far.

I have an ubuntu 18.04 LTS machine running sickchill and sabnzbd without any problems, but the configuration itself is a bit oversized and not ideal. So I decided to set up a completely new system based on a PI4 with OMV5 and Docker.

I was able to deploy the containers linuxserver/sabnzbd:latest and linuxserver/sickchill:latest without major problems: sickchill and sabnzbd work as expected (i.e. exactly as expected from my ubuntu 18.04 LTS machine).

The only thing I didn’t get to work is nzbToMedia: I just can’t get sabnzbd to run the postprocessing script After downloading a nzb, sabnzbd gives the following error message: “Exit(-1) Cannot run script /config/scripts/nzbToMedia/”.

These are the steps I tried to so far:

  1. I set PUID and GUID according to the user pi, ie 1000 and 1000, resp
  2. as user pi, i created a sub-dir to /config called /scripts
  3. I cd’ed into the /config/scripts/ and installed via git git clone
  4. I changed autoProcessMedia.cfg according to the changes I made on my ubuntu 18.04 LTS
  5. I made the script executable by sudo chmod +x
  6. I checked that the directory is owned by pi resp that pi has all the permissions:
    pi@omv:/srv/dev-disk-by-label<LABEL>/config/sabnzbd/scripts $ ls -la
    total 24
    drwxrwxrwx+ 3 pi pi 4096 Mar 24 16:40 .
    drwxrwxrwx+ 6 pi users 4096 Mar 24 20:19 ..
    drwxrwxrwx+ 8 pi pi 4096 Mar 24 20:09 nzbToMedia
  7. In the config of sabnuzbd i set similar settings as on my ubuntu machine

I’m stuck! I don’t understand why sabnzbd does not even run the script (that’s at least my understanding of the error message). Do I have to change something in the header of

Currently it reads:
#!/usr/bin/env python
# coding=utf-8

If I check python in OMV with which python I get /usr/bin/python, which is the same as on my ubuntu machine.

Best, Markus