Linuxserver/transmission - can the webUI be accessed without password?


Running linuxserver/transmission:latest under Docker 5:19.03.13~3-0~debian-buster

Can I somehow configure the container to NOT request any credentials when opening the webUI? I have tried a few things, but to no avail. Here is my Compose file:

version: “2.1”
image: linuxserver/transmission
container_name: transmission
- PUID=1003
- PGID=1002
- TZ=Europe/Warsaw

- USER=username #optional

- PASS=password #optional

  - /srv/dev-disk-by-id-ata-XXX/AppConfigs/transmission:/config
  - /srv/dev-disk-by-id-ata-XXX/Downloads/transmission:/downloads
  - /srv/dev-disk-by-id-ata-XXX/Downloads/transmission/watch:/watch
  - 9091:9091
  - 51413:51413
  - 51413:51413/udp
restart: unless-stopped

stop and rm; remove the user and pass sections in your compose, then pull and up again

you defined a user/pass, so it’s making you use it.

Oh, sorry, I didn’t put my pasted Compose file into code markup.

The USER/PASS entries were commented out with a hash character.
Also, after removing them completely and redeploying stack (via Portainer, if it matters) - the credentials are still requested.

Generically speaking, i blame portainer for any weird behavior, there is a reason libcompose was deprecated YEARS ago :stuck_out_tongue: We never recommend using it except for viewing.

That said, if you originally deployed with user/pass, you would need to deleted the /config so you get a clean config. though i suppose, more specifically, you can go to /srv/dev-disk-by-id-ata-XXX/AppConfigs/transmission/ and delete settings.json

changing envvars in compose doesnt do much once the config is made without blowing it away. i tend to do something like

docker stop
docker rm
rm -rf /path/to//
then pull and up.

Thank you, that did the trick (I just had to manually set rpc-host-whitelist in settings.json).

This is my first brush with Docker, so I am not aware of all the subtle interop issues.

no worries man, glad you’re working :slight_smile:

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.