Linuxserver/tvheadend DVB network types unavailable

tvheadend

#1

Hello folks,

I am attempting to configure the TVheadend container for use with DVB. I am using a Hauppauge WinTV-HVR-955Q which I have used successfully with TVheadend in the past on a Raspberry Pi. I am no longer running on a Raspberry Pi, just a standard i5 box, figured I’d mention this in case it matters.

This is the create command that I used:

docker create
–name=tvheadend
–restart=always
–net=bridge
-v /home/docker/tvheadend/config:/config
-v /home/docker/tvheadend/recordings:/recordings
-e PUID=1001 -e PGID=1001
-p 9981:9981
-p 9982:9982
–device=/dev/dvb
–device=/dev/dri
linuxserver/tvheadend

If I try to run the container without my DVB adapter connected it throws an error, but everything runs smoothly when the adapter is connected. This leads me to believe that Ubuntu and my container are seeing the DVB adapter, but when I go through the setup wizard the “Tuner and Network” section only lists “IPTV Automatic Network” under network type.

All I want is for TVheadend to see my DVB adapter so I can scan for my local services, but I can’t seem to figure out how to enable DVB. Any help would be appreciated! Thanks in advance!


#2

You need to chown the /dev/dvb device to the same user as the PUID/PGID that you’re running the container as :slight_smile:


#3

Thanks for your help j0nnymoe.

I ran chown on the /dev/dvb device as follows:

sudo chown 1001 /dev/dvb

Changing ownership seemed to work out fine.

I was still having issues so I tried force deleting the container and removing the /home/docker/tvheadend directory and contents. Upon recreating the container using my previous command I am again seeing no available DVB tuner under network type on the 3rd page of the setup wizard.

Do you have any other suggestions for me? Thanks again for the response.


#4

Does anyone have any recommendations for me? I’m still at a loss here.

I have tried the following on Ubuntu server:

sudo chown 1001:1001 /dev/dvb

I have tried the following in the Docker container:

chown 1001:1001 /dev/dvb

Both commands executed without errors, but I still don’t see my DVB tuner listed under networks.
I have tried force deleting my container and the /home/docker/tvheadend folder and starting fresh with the same results. I’m not sure what I’m doing wrong here. Any help would be appreciated!


#5

You should chown the device recursively, as it’s the adapters TVH needs access to.

sudo chown -R /dev/dvb

#6

Thank you sir! That did the trick.

I actually tried searching for this post through Google last night since I was on a different PC where I didn’t have it bookmarked. I stumbled upon this post which referenced running chown recursively with -R, so that was on my to try list for the day.

I really appreciate the help. Now I can figure out something new to do with my Pi!