Linuxserver/tvheadend + QNAP + USB DVB dongle => missing something

tvheadend

#1

Hi,

i followed the Wonderful guide on the blog to setup Linuxserver/tvheadend with container station on QNAP!, sadly for me i’m having a DVB USB device, so i couldn’t be helped by the screenshots to know how to fill the advanced setting forms. Still i could guess what i was missing after a while.
The container is working and tvheadend seems to work completely…
BUT, i’m facing an issue which somehow compromise for me the interest of the whole how to, as the given example possibly couldn’t work!

The problem as far as i understand it, is that my DVB USB tuner is not recognized on the new QTS version of my QNAP. (QNAP removed the support for DVB Tuners recently, speaking about compatibility problems.)

So on the host my USB device doesn’t create a /dev/dvb and doesn’t load any driver or firmware as well.
Still the USB device appears on the lsusb.

In the create container i added “videoforlinux” in the “advanced settings”->“device” because it is the only thing i can see that could possibly match.
But it still doesn’t work in the container. (which is logic if the container expect /dev/dvb!)

I cannot be sure of the docker command line used by Container Station since i don’t know how to see it. Maybe it is simply in the processes… i haven’t tried.

I opened a console in the container and did a lsusb, and i can see the usb device (so raw usb can be seen?), but once again no /dev/dvb. (no driver on the container i suppose)

My question is: where shall be the driver? on the host? in the container?
if the driver has to be on the host, i will probably have the same trouble than QNAP had about compatibility and probably couldn’t build the driver or find a suitable v4L already made.
if the driver can be in the container, then is the docker transporting the raw usb device (from lsusb) so-that the container can mount a module with driver and create a /dev/dvb inside the container ? then in this case is there any container which include all dvb drivers? can we expect one from linuxserver.io?

I will try with a full VM with ubuntu to see if such “full weight” VM can see the USB and load the drivers, but if it works, it would be wonderful to have a container all in one which also include the dvb drivers.

Am i wrong in what i say? any other way?

For information, i’m having a QNAP TS-453Be (x64 i think) with latest QTS, and the usb dvb device is the “sony play TV dual tuner”
I use this device successfully with another QNAP TS-421 (arm) i own, which is stuck to an old QTS version that still contains drivers.

Thanks in advance for any clue to make it work or at least to figure out the problem.


#2

I just replied to your comment on the article :stuck_out_tongue:
The post didn’t get deleted, just needed to be approved due to the length.

Unfortunately you need to have the DVB Drivers on the host and not in the container. You’ll have to contact QNAP to see if they can include it again.


#3

ok sorry for double answer then haha.
hum, so i suppose that you also tell me that for you it is impossible to have such a driver directly put inside the linuxserver/tvheadend tiny linux vm. probably too limited linux?
then do you think i would have more chance with a full weight VM? if the VM has access to the hardware, it can use it with his own driver, no?
i’ve seen some tvheadend containers with already bundled driver for a specific DVB (sadly not mine) so i suppose some people got into trouble to add such drivers into containers for a reason. it may work… no?


#4

We wouldn’t want to include drivers with our containers as there is generally no need for it if they are on the host.

Yea the best route if you want to use your qnap is to setup a VM and pass the device through to that.


#5

ok, that make sense, and i better understand your previous answer.
Still i loved the idea that “all is in the box”, no matter where you run your container, you don’t have to deal with extra installation/dependencies. In my case the container depends on a driver… so it doesn’t work as an “all in one”.

As a conclusion, you won’t do it, but it might work!

So either i find a way to do it myself and create my own container, either i run a full VM with ubuntu.

Thanks for your explanations :smiley: that’s been of great help!


#6

[SOLVED!]
Just a follow up.
Seeking for the driver for the host, i discovered that there is a whole native tvheadend QPKG made by someone but hidden in the forum http://forum.qnap.com
The pages can only be found if you own an account on this forum and they are not indexed on any search engine, so that’s why i couldn’t find that information.
They provide within the package all the drivers and firmware required and a recent version of tvheadend.
So i don’t actually need to use any container or VM!
Still that was a nice introduction to that world for me. so thanks again.