Lsioarmhf/qbittorrent not downloading in desired downloads volume


#1

greetings LSIO

followed the instructions
everything works fine (config and SSL too) except downloads
it’s downloading in docker temp volume and not in the desired given volume

PUID 1001 have full permission on /sharedfolders/downloads folder
even tried chmod -R 777 /sharedfolders/downloads
tried giving root IDs and UMASK_SET=022 too but no gain

here my docker create command:

docker create
docker create \
  --name=qbittorrent \
  --net=host \
  -v /docker/qbittorrent:/config \
  -v /sharedfolders/downloads:/downloads \
  -e PGID=100 -e PUID=1001  \
  lsioarmhf/qbittorrent

log shows nothing wrong:

docker log -f
docker logs -f qbittorrent
[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] 10-adduser: executing...
-------------------------------------
GID/UID
-------------------------------------

User uid:    0
User gid:    0
-------------------------------------

[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 30-config: executing...
[cont-init.d] 30-config: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.

******** Information ********
To control qBittorrent, access the Web UI at http://localhost:8080
The Web UI administrator user name is: bonga

what seems to be the problem?
can you guys help this out?


#2

fixed it :expressionless:
download folder location was set to downloads/, as it should be /downloads/ :disappointed:
wonder have many times i have recreated container and image and wiping config folder but this happened :frowning_face:
mods you can close this thread