MariaDB Log consumes a lot of disk space

Hello, I am getting desperate right now…
I have created via Portainer Stacks the container as follows:

Version: "2.1"
    container_name: linuxserver_mariadb
      - PUID=1000
      - PGID=1000
      - MYSQL_ROOT_PASSWORD=mypassword
      - TZ=Europe/Berlin
      - /portainer/files/AppData/Config/linuxserver/mariadb:/config
      - 44445:3306
    Restart: if not stopped

Unfortunately, MariaDB fills the log with ~7GB over a day. The files are e.g. mariadb-bin.0000XX, mariadb-bin.index etc. The logging driver is set to local. Now the question, is there any way not to create bin logs? And how do I get logrotate to work?

Your best bet it to look into mariadb configs and see what you’re willing to adjust and to what level. changing bin logs without understanding them can lead you to a sad day.

My EXTREMELY heavily used database (it’s a db for 12 different systems) is 2GB of space used including binlogs. All of my settings are the default for our container. (ie, same as you would have using a fresh container). I do zero maintenance/cleanup i’ve never seen it exceed 2G. Most of that data is indeed the binlogs (826MB of it)

i would suggest starting here
mysql - Maximum overall size of MariaDB binary logs - Database Administrators Stack Exchange

we also don’t support deploying our containers with portainer, it causes a myriad of issues. This isn’t a discussion point and doesn’t need feedback, it’s just a statement of our support stance.