Muximux not accessible on Ubuntu 18.06

muximux

#1

I’m trying to get muximux up and running but I have had no luck I’m using traefik as a reverse proxy so I thought that may be an issue but it’s not even accessible via my local network. I haven’t had any other issues with any of my other docker images and they are all up and running fine.

This is the section of my docker-compose file
muximux:
container_name: muximux
restart: always
image: linuxserver/muximux
volumes:
- ${USERDIR}/docker/muximux/data:/config
ports:
- “90:90”
environment:
- PUID=${PUID}
- PGID=${PGID}
- TZ=${TZ}
networks:
- traefik_proxy
labels:
- “traefik.enable=true”
- “traefik.backend=muximux”
- “traefik.frontend.rule=Host:home.${DOMAINNAME}”
- “traefik.port=90”
- “traefik.protocol=https”
- “traefik.docker.network=traefik_proxy”
- “traefik.frontend.headers.SSLRedirect=true”
- “traefik.frontend.headers.STSSeconds=315360000”
- “traefik.frontend.headers.browserXSSFilter=true”
- “traefik.frontend.headers.contentTypeNosniff=true”
- “traefik.frontend.headers.forceSTSHeader=true”
- “traefik.frontend.headers.SSLHost=zarioth.com
- “traefik.frontend.headers.STSIncludeSubdomains=true”
- “traefik.frontend.headers.STSPreload=true”
- “traefik.frontend.headers.frameDeny=false”

And this is my traefik.toml file
debug = true

logLevel = "DEBUG" #DEBUG, INFO, WARN, ERROR, FATAL, PANIC
InsecureSkipVerify = true 
defaultEntryPoints = ["https", "http"]

# WEB interface of Traefik - it will show web page with overview of frontend and backend configurations 
[api]
  entryPoint = "traefik"
  dashboard = true
  address = ":8080"
  usersFile = "/shared/.htpasswd"

# Force HTTPS
[entryPoints]
  [entryPoints.http]
  address = ":80"
    [entryPoints.http.tls]
  [entryPoints.https]
  address = ":443"
    [entryPoints.https.tls]

[traefikLog]
  filePath = "~/docker/traefik/traefik.json"
  format   = "json"

[accessLog]
  filePath = "~/docker/traefik/access.log"
  format = "json"
#[file]
#  watch = true
#  filename = "/etc/traefik/rules.toml"

# Let's encrypt configuration
[acme]
email = "xxx@xxx.com" #any email id will work
storage="/etc/traefik/acme/acme.json"
entryPoint = "https"
acmeLogging=true 
onDemand = false #create certificate when container is created
[acme.dnsChallenge]
  provider = "cloudflare"
  delayBeforeCheck = 0
[[acme.domains]]
   main = "xxx.com"
[[acme.domains]]
   main = "*.xxx.com"
   
# Connection to docker host system (docker.sock)
[docker]
endpoint = "unix:///var/run/docker.sock"
domain = "xxx.com"
watch = true
# This will hide all docker containers that don't have explicitly  
# set label to "enable"
exposedbydefault = false

#2

Muximux runs on port 80, not port 90.