Newbie can't access Ubooquity on Synology DS 918+

ubooquity

#1

Hi, I should start by saying that I am a newbie at using Docker and things outside a Windows environment so apologies in advance if this is a Synology issue rather than something with the container.

I’ve been trying to get Ubooquity up and running on my DS 918+ but can’t access it. Not sure where the problem lies exactly. Docker is installed and running, I can see the container as running in Docker and there is nothing obvious in the logs to suggest a problem. However, when I try to access the admin settings via http://ip:2203, I get “This site can’t be reached ip refused to connect”.

Are there any prerequisites I need to install like Apache or Web Station or should the container “just work”?

Any pointers on how to proceed would be appreciated.

Guy


#2

If you followed the directions in the readme, it should just work.

So you need to give us more info on how you set it up before we can help troubleshoot


#3

Where do I find the readme?


#4

https://github.com/linuxserver/docker-ubooquity or https://hub.docker.com/r/linuxserver/ubooquity


#5

Thanks. I had read those but hadn’t been able to decipherable how to translate them into what I need to do in docker. Am I supposed to be doing something via Putty or in the docker terminal window?


#6

You can do docker exec -it containername bash via putty or I suspect Synology have a way of entering the container via their webui.


#7

OK, that’s really helpful. I amended it to:

sudo docker exec -it linuxserver-ubooquity1 bash

and entered the admin password when prompted which takes me to

root@linuxserver-ubooquity1:/$

But if I then enter

id <dockeruser> ; uid=1001(dockeruser) gid=1001(dockergroup) groups=1001(dockergroup)

as per the readme I get

bash: syntax error near unexpected token `('

#8

I have to be honest, I’m not entirely sure what you are trying to do. If you are just trying to get the container up and running, I would recommend deleting what you have and starting fresh.

Take the command from the readme:

docker create \
  --name=ubooquity \
  -v <path to data>:/config \
  -v <path to books>:/books \
  -v <path to comics>:/comics \
  -v <path to raw files>:/files \
  -e MAXMEM=<maxmem> \
  -e PGID=<gid> -e PUID=<uid>  \
  -p 2202:2202 \
  -p 2203:2203 \
  linuxserver/ubooquity

Adapt that accordingly to your synology nas. We don’t have any synology hardware within the group so any support we give for that platform is best effort. I would recommend finding a guide for setting up -any- of our containers on a synology nas and adapt it accordingly to this.


#9

Thanks. As noted in my original message, I’m not sure whether the problem I have is because the container isn’t setup right or something entirely different which prevents me from accessing the admin (or user) pages. So I thought it best to try to confirm the container setup first.

I think I’ve worked out how to specify the paths for the container (there is an option for this in the GUI, and I can see that ports are setup to forward internal ports to 2202 / 2203. The thing that might be an issue is the PGID and PUID. What does “-e” do? Is that specifying an environment variable? Are gid and uid group and user IDs respectively?

In the GUI for the container options there is currently an environment variable of PS1 which has the value $(whoami)@$(hostname):$(pwd)$ specified - I tried adjusting this to be my admin user credentials but got nowhere with it. Do you think I need to add PGID / PUID as variables and then appropriate values that relate to my system?

In case none of the above makes much sense (which seems likely) I’ll keep hunting for some sort of guide for running your containers on Docker on a Synology. I’ve had no luck on that front so far which is why I reverted to the forum but hopefully someone out there has done it and written it up.


#10

Bad form I know to reply to my own post, but courtesy of a few different search terms I’ve found this guide which shows adding the PGID and PUID as environment variables, obtaining the uid and gid by just accessing the NAS via Putty and typing id at the command prompt (which then returns the various values).

Having added these to the config through the GUI I can now see in the logs that on startup it has scanned the comics folder I pointed it at. So I’m pretty sure that the container is working.

I still can’t access the thing through the web interface though. But that suggests it is either something with Docker or something with my NAS config.

Thanks for the help.


#11

And to close the loop on this, I can now confirm that I am indeed an idiot - I was reading the port numbers backwards and trying to access via 2202 / 2203 when in fact the outward-facing ports were being set automatically as different numbers. Having now gone in and specified them as the same port numbers, it all appears to be working.


#12

I am in literally the exact same boat. Tried installing ubooquity to no avail. Found the docker version and hoped it was easier but the guide is impossible to understand.
I was able to get the container installed but have no idea where to input the info they are noting. I found the terminal and assume it may be here but am unsure how. Fairly tech savvy but this is not clear. Any help would be much appreciated.
My storage volume is called Palmiter and the shared folder with comic directories is Comics.


#13

I ended up using the info from this guide to get mine running: https://drfrankenstein.co.uk/2016/05/14/setting-up-nzbget-in-docker-on-a-synology-nas/

In brief:

  1. Install Docker
  2. Install Ubooquity container
  3. Instal Putty on your PC
  4. Use Putty to login to your Synology NAS with the credentials of the user you want to setup Ubooquity with and then just type

id

  1. This will give you a UID (which is your PUID) and a GID (which is your PGID) - either note the numbers down or leave the window open as you’ll need them later.
  2. Launch the container (or if already installed, stop it (if running) and click edit
  3. Under “Volume”, you want to add at least two folders - one for the config and one for the comics (plus any others for books or raw files). Click add folder and tell Ubooquity where your comics folder is then assign this a mount path of /comics, I followed the guide and created a config folder called Ubooquity1 in the docker folder (so I can have multiple instances of ubooquity running if needed by creating ubooquity2 etc as future config folders)
  4. Under port settings, in place of auto specify the ports you want to use to access ubooquity - these can be the same as ubooquity or anything else that isn’t already in use.
  5. in environment, add two new variables - PGID and PUID, setting the values as whatever you got from Putty previously
  6. Hit apply and start the container, then go to:

http://<your_ip>:<your_admin_port>/ubooquity/admin

In my case that translates to:

http://192.168.1.107:2203/ubooquity/admin

And that should be it. The guide I linked to up top includes screenshots and is generally better written than this quick summary so worth a look.