Nextcloud .ocdata not being written to

Hi all,

I’m using nextcloud by on my Unraid server. So far it has been working pretty well. However, about a month ago I shut down my server and I was unable to boot nextcloud again, getting the error that “Data directory is invalid. Please check that the data directory contains a file “.ocdata” in its root”. I wasn’t able to find the issue so I reinstalled the image, flashed the data, config, and the DB.

I’ve now been running the image for a month and I’ve just now noticed that the .ocdata file in the data directory exists, but is empty. I’ve tried touch .ocdata, which updates the modification date, but it’s still 0 bytes. Lastly, I’ve used chown -R 99:100 on both the data and config directory, but it’s still an empty file. I’ve noticed that the log file in the same directory is being written to, so it seems to have read/write to the dir.

At this point I don’t want to shut the image down (or my server) for the fear of nextcloud not being able to startup again. What can I do to remedy this?

Regards, Anthony


what are you trying to remedy? as you’ve described it things seem fine now… is there some official documentation from NC that imply .ocdata should not be 0 bytes? please share the link

as a note, we support the container, not the application within the container, that support comes from nextcloud, though we are happy to help when sufficient information is provided to enable us to do so.

I haven’t found any information that says it should be a non-zero size. However, the last time I tried to start the container again with the .ocdata being 0 bytes, it failed to start, as I mentioned earlier.

mine is 0 and my instance has been working fine for years. I’m not sure i understand what you’re trying to accomplish. your failure to start was likely some host related issue or failure to maintain

driz, respectfully, please re-read my initial post. I have made it clear that my issue is related to the fact that my .ocdata file is “missing”, as thought by the program. What I’m trying to accomplish is to avoid this error.

I read your original post, now you say it’s there and 0 bytes which is normal.

Good morning,

I believe there was a bug in one of the releases from August to September, as I successfully updated my container last week without the .ocdata issue. I also enabled maintenance:mode before the installation and disabled it afterward.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.