No images seem to be OCI compliant

I’ve tried to run any image with podman and none of them work at all. They all fail with this same error, what is the issue?

[jugs@cube ~]$ sudo podman run lsiobase/ubuntu:bionic
Trying to pull
Getting image source signatures
Copying blob 365fb4258aff done
Copying blob d6ba4c98da8e done
Copying blob 724682e7cc32 done
Copying blob d58a1db0701e done
Copying config 45653516c5 done
Writing manifest to image destination
Storing signatures
Error: error executing hook /usr/libexec/oci/hooks.d/oci-systemd-hook (exit code: 1): OCI runtime error

Can close, this only is an issue when the oci-systemd-hook package is installed.

This post is over two weeks old, but I’ll leave this for reference:

The oci-systemd-hook package is (I think, but I might be wrong) a component of Podman’s ability to run containers without root, as an extra step of caution for packages that don’t need privileges such as port mapping. [Source]

Adding --systemd=false to your input creates an exemption for a container.