Not able to create cert for Nextcloud

I have used the Nextcloud and Let’s Encrypt containers, I have namecheap as a dns and the ddns set up in my ASUS Merlin router.

Errors I get are:
Challenge failed for domain
DNS problem: NXDOMAIN looking up A for mydomain
No valid IP addresses found for myddns
Timeout during connect (likely firewall problem)


I’ve got the cname in namecheap, port forwarded in router, config instructions have been followed for nextcloud, adding the overwrite_url stuff.

Looks like the url you are using does not have the correct A record (points to IP) on your dns provider.

Check here to confirm:

Or maybe you set it, but it didn’t propagate to other servers yet. If that’s the case, I would recommend moving your nameservers to cloudflare because their dns changes propagate almost immediately

Okay so let’s pretend you are talking to a 5 year old that has a working Nextcloud instance.

How do you go about setting up lets encrypt assuming you have a working ddns? I tried following the readme’s but somehow broke connectivity to emby in the process and had to undo everything I’ve done today to get that back to working order. So yeah I went full retard somehow. I just don’t know what did it…

Can your router update your ip on cloudflare? If so, forget the ddns.

Register a free cloudflare account, it will guide you through moving your name servers there. Then you can easily create an A record that points to your home ip, and a CNAME for “*” which is wildcard and have that point to your A record.

Then follow this guide:

So one question, if I have to forward the port on the router, how can I have more than one container set up to use ssl?

@aptalca literally linked it in his post. You use a reverse proxy that everything goes through.

I guess I will see once I update Cloudflare. According to the link it still looks like I’m having to use different ports.

Edit. Yup I had to use cloudflare.

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.