Nzbget problems cant start after redo

Wondering if anyone can offer a tip. Using podman as I would rather go rootless. First time I tried nzbget I couldnt get it to work. Tried removing to start over. Took a lot longer than I through and wasnt as simple as rm nzbget. When I reinstall it and go to run I get this error:

Error: rootlessport listen tcp bind: address already in use

And cant find anything on how to work around. Running port -a doesnt even show 6789 in use. Now sure how to search this out to remove the old bind.

reinstalled a different operating system. ran:

podman run \
-e TZ=America/New_York
-p 6789:6789
-v /Tank/DownloadApps/Nzbget:/config
-v /home/media/downloads/:/downloads
–restart always

and didnt figure way around permission errors. Want to change a parameter on where the main download directory is but dont want to reinstall if it goes wrong. Last time I removed a container I could not reinstall or pull the same container again due to names still being in place and ports still being bound for the previous instance. Since removing didnt completely remove I want to know where the config files are kept so I can edit the main folder line. Cant find in .local/* Want to edit to save the first install but cant figure out where to edit or where the ssl folders would be or webui folders, etc.

confirmed. Had to install cockpit to be able to cleanly remove an container or so I thought. I removed the container I had that would not start for nzbget and then I made another one with the desired settings. Why would it be that the second container started with the settings I made for the first container and ignored what I typed to start the 2nd?

as a note we do not support rootless nor do we test on podman in any way. while it should work when NOT using rootless, we do not support it.

Thank you for your reply. Understood. Thank you. So far I have radarr, sonarr and jellyfin working well. This posting is my mistake after looking at further. I messed up the compose file for lidarr accidentally doing a copy and paste mistake. I’ll skip lidarr for now. Setting uid and gid to 1000 for user accessing was needed for rootless. Chowing as also needed for the files / directories services will access. Containers working well. Thanks again