NZBHydra2 Image - Unable to update from 2.19.16 to 3.8.1

I have been using docker images for some time in a Ubuntu environment, however, I am not a CLI expert and outside of the initial yaml scripting, mostly use web interfaces like portainr and watchtower to keep my Docker environment up to date. Up until now everything has been working perfectly.
I have a NZBHydra Image from April 2020 which refuses to update to the 3.8.1 image either automatically via Watchtower or Manually via Portainr or from the CLI (docker-compose -f ~/docker/docker-compose.yml up -d --remove-orphans).
I have tried restarting the containers and the hardware. The docker-compose script tells me that all my images are up-to-date but when I use Hydra I still get the out-of-date message and the image metadata has not changed.
Can anybody help me find out what the issue is?
Many Thanks and a Happy New Year
PS Here ist the YAML code
hydra2: image: "linuxserver/hydra2" container_name: "hydra2" volumes: - ${USERDIR}/docker/hydra2:/config - ${USERDIR}/docker/shared:/shared - "/media/nas_download:/nas_download" - "/media/PlexMedia:/PlexMedia" ports: - "5076:5076" restart: always environment: - PUID=${PUID} - PGID=${PGID} - TZ=${TZ}

The container got renamed from hydra2 to nzbhydra2 (It should alert you about this in the logs).

Ok. Thanks for that.
I’ll look in the Documentation to find out where the logs are, for next time :slight_smile:
Can I get the new Image into my Environment, without loosing any config etc?
Can I just change my Yaml script for the New name?