Overseerr - 1.30.1-ls49 - Error on arm64v8 version

Hello,
I create the Overseerr container with arm64v8 version on the NAS (with Realtek RTD1296), but I get the followings error after start the container.
What’s the possible root cause of this issue?

Error: ENOENT: no such file or directory, open ‘/usr/share/node_modules/yarn/lib/cli’
at Object.openSync (node:fs:594:3)
at Object.readFileSync (node:fs:462:35)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1143:18)
at Module.load (node:internal/modules/cjs/loader:1004:32)
at Function.Module._load (node:internal/modules/cjs/loader:839:12)
at Module.require (node:internal/modules/cjs/loader:1028:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (/usr/share/node_modules/yarn/bin/yarn.js:24:13)
at Module._compile (node:internal/modules/cjs/loader:1126:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1180:10) {
errno: -2,
syscall: ‘open’,
code: ‘ENOENT’,
path: ‘/usr/share/node_modules/yarn/lib/cli’
}
node:internal/fs/utils:347
throw err;
^

Thanks a lot!!

Hey Patrick,

I’m the one who sent you that email asking if you could publish Overseerr in App Central :slight_smile: I have the exact same error message when trying to setup the docker image on my Asustor AS1102T NAS (ARM CPU). Another user that has a Lockerstor NAS model (Intel CPU) does not have this issue (he told me so here).

Thanks so much for looking into it! Hopefully you’ll get a reply

I received some things to try from the discord chat:

  1. Add this to the docker-compose (this comes from this FAQ):
    security_opt:
    - seccomp=unconfined
  1. If still not working, try to setup the container without using Portainer
  2. If still not working, hope that ASUSTOR releases a more recent version of docker at some point in the future…

Hey Patrick :slightly_smiling_face: I tested adding the seccomp=unconfined option but no luck (the same error message). I also tried uninstalling Portainer and using docker-run via the cli, but same result. The version of docker on the NAS is 20.10.17.r1 (which is above the version mentioned in the FAQ - 20.10.10)

Yes, I also tried the solution you mentioned, but same error there.
I cannot get Overseerr works on arm64 platform now.